summaryrefslogtreecommitdiff
path: root/dev-cpp/notcurses
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/notcurses')
-rw-r--r--dev-cpp/notcurses/Manifest4
-rw-r--r--dev-cpp/notcurses/metadata.xml22
-rw-r--r--dev-cpp/notcurses/notcurses-2.2.3.ebuild50
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-cpp/notcurses/Manifest b/dev-cpp/notcurses/Manifest
new file mode 100644
index 000000000000..2f98f191a346
--- /dev/null
+++ b/dev-cpp/notcurses/Manifest
@@ -0,0 +1,4 @@
+DIST notcurses-2.2.3.tar.gz 10861361 BLAKE2B e7b487e84b5defbb1208f355c85f7178b05f412c2a746a8bcecb2da7db8df32da563aeb1f1f218014a2ff9803f0984889e4341d59f585add49c944d4707e5cd4 SHA512 9c718a39352cc10e4f4cb24cd7940ccc7ac7ad1f5890f1a87166267b3c24011629464a4720f08c2b8bbf0fab2c5cb9b31fba7a43bc62ae65dff894019adece7d
+DIST notcurses-doc-2.2.3.tar.gz 89550 BLAKE2B a42c74f95166e48ecff99a05d66925869a44a44c4faa867cca663d94ee340748417d6560d022fdb90c7761c19285b0c4838b75843a3d26d25182977f68a0d6ce SHA512 b61f829d1ad5f69147a7b4fe139db406d5a26683b55d72251f3e313c17f591ad4e9e868577fbecf86c4ac9959c942e244927fb29a2e44996fadde7946493ccc8
+EBUILD notcurses-2.2.3.ebuild 1139 BLAKE2B b3f88e3e18ce6bdbac48fbc24f701e723015538c5bab4608fc3e114e7f783b5b3e732e9d6c28ff794e964655192af9a77489c48094decdba4d380f21be2bc314 SHA512 f28252268d25f06eb33659340e10f11316989df79bbedbf7793a313a0d9d005fa8e31353f93d9f485342d733c10c3dc2ada1893ed1d28c7163f061bcf5561ce3
+MISC metadata.xml 869 BLAKE2B c5414b2e27b44526c56e9c476d8c5540a3d7b462b70ed6e3e323c0dbee15c704055cc7d17bf270fbb7a6125bfa10a2934c9d56d5c727d73df0c8125ec30671d6 SHA512 f893bc5d9b44d26e178250432be8762524543f0c124c932d535e4f9742924d27a26b065a5d1275dc451f23b0ff72a55a2f5107749021081e7e399617de132f17
diff --git a/dev-cpp/notcurses/metadata.xml b/dev-cpp/notcurses/metadata.xml
new file mode 100644
index 000000000000..3fe0567d3e8b
--- /dev/null
+++ b/dev-cpp/notcurses/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dankamongmen@gmail.com</email>
+ <name>nick black</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Notcurses facilitates the creation of modern TUI programs,
+ making full use of Unicode and 24-bit TrueColor. It presents
+ an API similar to that of Curses, and rides atop Terminfo.
+ </longdescription>
+ <longdescription lang="es">
+ Notcurses facilita la creación de programas TUI actuales,
+ haciendo un uso completo de Unicode y color real de 24 bits.
+ Presenta una API similar a la de Curses y funciona sobre Terminfo.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-cpp/notcurses/notcurses-2.2.3.ebuild b/dev-cpp/notcurses/notcurses-2.2.3.ebuild
new file mode 100644
index 000000000000..52303eeff6fe
--- /dev/null
+++ b/dev-cpp/notcurses/notcurses-2.2.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS="cmake"
+inherit cmake-multilib
+
+DESCRIPTION="Blingful TUIs and character graphics"
+HOMEPAGE="https://notcurses.com"
+SRC_URI="https://github.com/dankamongmen/notcurses/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/dankamongmen/notcurses/releases/download/v${PV}/notcurses-doc-${PV}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/libunistring
+ media-video/ffmpeg
+ >=sys-libs/readline-8.0"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_DOCTEST=OFF
+ -DUSE_MULTIMEDIA=ffmpeg
+ -DUSE_PANDOC=OFF
+ -DUSE_QRCODEGEN=OFF
+ -DUSE_STATIC=OFF
+ )
+ cmake-multilib_src_configure
+}
+
+src_compile() {
+ cmake-multilib_src_compile
+}
+
+src_test() {
+ multilib_src_test
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ # we use this tortured form lest we try, every time we release a
+ # x.y.1 or x.y.3, to install the source dir as a man page.
+ # exploit the fact that there's a bijection from html<>man.
+ for i in ../*.html ; do
+ doman ../$(basename ${i} .html)
+ done
+}