summaryrefslogtreecommitdiff
path: root/dev-cpp/nlohmann_json/nlohmann_json-3.11.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/nlohmann_json/nlohmann_json-3.11.2.ebuild')
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.11.2.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.11.2.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.11.2.ebuild
index c631bc6644a9..3bac320e3a05 100644
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.11.2.ebuild
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.11.2.ebuild
@@ -51,10 +51,14 @@ src_configure() {
src_test() {
cd "${BUILD_DIR}"/tests || die
+ # git_required:
# Skip certain tests needing git per upstream
# https://github.com/nlohmann/json/issues/2189
+ #
+ # cmake_fetch_content_configure, cmake_fetch_content2_configure:
+ # Needs network (bug #865027, bug #865105)
local myctestargs=(
- "-LE git_required"
+ -E "(git_required|cmake_fetch_content_configure|cmake_fetch_content2_configure|cmake_fetch_content_build|cmake_fetch_content2_build)"
)
cmake_src_test