summaryrefslogtreecommitdiff
path: root/dev-cpp/libcmis/libcmis-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/libcmis/libcmis-9999.ebuild')
-rw-r--r--dev-cpp/libcmis/libcmis-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-cpp/libcmis/libcmis-9999.ebuild b/dev-cpp/libcmis/libcmis-9999.ebuild
index 10de5182674b..1d4b60e4cd0e 100644
--- a/dev-cpp/libcmis/libcmis-9999.ebuild
+++ b/dev-cpp/libcmis/libcmis-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,7 +8,7 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
else
SRC_URI="https://github.com/tdf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
fi
inherit autotools
@@ -16,7 +16,7 @@ DESCRIPTION="C++ client library for the CMIS interface"
HOMEPAGE="https://github.com/tdf/libcmis"
LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
-SLOT="0.5"
+SLOT="0/0.6"
IUSE="man test tools"
RESTRICT="test"
@@ -26,7 +26,9 @@ DEPEND="
dev-libs/libxml2
net-misc/curl
"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-cpp/libcmis:0.5
+"
BDEPEND="
virtual/pkgconfig
man? (
@@ -46,7 +48,6 @@ src_prepare() {
src_configure() {
local myeconfargs=(
- --program-suffix=-$(ver_cut 1-2)
--disable-werror
$(use_with man)
$(use_enable test tests)