summaryrefslogtreecommitdiff
path: root/dev-cpp/kokkos/kokkos-3.1.01.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/kokkos/kokkos-3.1.01.ebuild')
-rw-r--r--dev-cpp/kokkos/kokkos-3.1.01.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/dev-cpp/kokkos/kokkos-3.1.01.ebuild b/dev-cpp/kokkos/kokkos-3.1.01.ebuild
index b8bceaa6fda8..2456f83dc2df 100644
--- a/dev-cpp/kokkos/kokkos-3.1.01.ebuild
+++ b/dev-cpp/kokkos/kokkos-3.1.01.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils toolchain-funcs
+inherit cmake toolchain-funcs
-DESCRIPTION="Kokkos C++ Performance Portability Programming EcoSystem"
+DESCRIPTION="C++ Performance Portability Programming EcoSystem"
HOMEPAGE="https://github.com/kokkos"
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
@@ -15,9 +15,7 @@ KEYWORDS="~amd64 -x86"
IUSE="+openmp test"
RESTRICT="!test? ( test )"
-DEPEND="
- sys-apps/hwloc
- "
+DEPEND="sys-apps/hwloc"
RDEPEND="${DEPEND}"
BDEPEND=""
@@ -41,5 +39,5 @@ src_configure() {
-DBUILD_SHARED_LIBS=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}