summaryrefslogtreecommitdiff
path: root/dev-cpp/gtest/gtest-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/gtest/gtest-9999.ebuild')
-rw-r--r--dev-cpp/gtest/gtest-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-cpp/gtest/gtest-9999.ebuild b/dev-cpp/gtest/gtest-9999.ebuild
index 02ca3c039b1a..ccb2185df0ae 100644
--- a/dev-cpp/gtest/gtest-9999.ebuild
+++ b/dev-cpp/gtest/gtest-9999.ebuild
@@ -13,12 +13,12 @@ if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/google/googletest"
else
if [[ -z ${GOOGLETEST_COMMIT} ]]; then
- MY_PV=release-${PV}
+ URI_PV=v${MY_PV:-${PV}}
else
- MY_PV=${GOOGLETEST_COMMIT}
+ URI_PV=${MY_PV:=${GOOGLETEST_COMMIT}}
fi
- SRC_URI="https://github.com/google/googletest/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+ SRC_URI="https://github.com/google/googletest/archive/${URI_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
S="${WORKDIR}"/googletest-${MY_PV}
fi