summaryrefslogtreecommitdiff
path: root/dev-cpp/gtest/gtest-1.9.0_pre20190607.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/gtest/gtest-1.9.0_pre20190607.ebuild')
-rw-r--r--dev-cpp/gtest/gtest-1.9.0_pre20190607.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-cpp/gtest/gtest-1.9.0_pre20190607.ebuild b/dev-cpp/gtest/gtest-1.9.0_pre20190607.ebuild
index 9a6cb10a49fd..3f9846728ea7 100644
--- a/dev-cpp/gtest/gtest-1.9.0_pre20190607.ebuild
+++ b/dev-cpp/gtest/gtest-1.9.0_pre20190607.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# Python is required for tests and some build tasks.
-PYTHON_COMPAT=( python2_7 pypy )
+PYTHON_COMPAT=( python2_7 )
+CMAKE_ECLASS=cmake
GOOGLETEST_COMMIT=da10da05c262af0a9e8fa91789a272a3dec67655
-
inherit cmake-multilib python-any-r1
if [[ ${PV} == "9999" ]]; then
@@ -44,7 +44,7 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -i -e '/set(cxx_base_flags /s:-Werror::' \
googletest/cmake/internal_utils.cmake || die "sed failed!"
@@ -60,7 +60,7 @@ multilib_src_configure() {
-Dgtest_build_tests=$(usex test)
-DPYTHON_EXECUTABLE="${PYTHON}"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_install_all() {