summaryrefslogtreecommitdiff
path: root/dev-cpp/gnome-vfsmm
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/gnome-vfsmm')
-rw-r--r--dev-cpp/gnome-vfsmm/Manifest3
-rw-r--r--dev-cpp/gnome-vfsmm/gnome-vfsmm-2.26.0-r1.ebuild57
-rw-r--r--dev-cpp/gnome-vfsmm/metadata.xml8
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-cpp/gnome-vfsmm/Manifest b/dev-cpp/gnome-vfsmm/Manifest
new file mode 100644
index 000000000000..5e61d30dbf73
--- /dev/null
+++ b/dev-cpp/gnome-vfsmm/Manifest
@@ -0,0 +1,3 @@
+DIST gnome-vfsmm-2.26.0.tar.bz2 628670 BLAKE2B d4fcd56518d7c7d2f385dcc559ea13c1fe636f2d6084be3a64d88baaba82e1d35dd45b6b5bd990f852525ad3a9fab5cb5a2470300882a3d201f3353cdd68876f SHA512 82e538c06615af83e9e455b0db601e37ee5396cac9b44884879383f3671876cca62bf534f4338177d1a62ab59e834d197302533dcc77f3c09b5433da9c660af8
+EBUILD gnome-vfsmm-2.26.0-r1.ebuild 1222 BLAKE2B 4b114cff30e1906fd191ca75d0bd182134ebc954e969ad07631cb63c7588c06de387ec3f63aa19fafff73c37a635cc6e6a0bd4ccf7b7057c8fb3ce0a0a8826e2 SHA512 ff7b2242b40605caec955879667a432a8730a915e25e03e49856f985ac2e9213cb8bf32f60d760696bf1daa622a9c4768f0b42f6908bde5aad68da76b077da4a
+MISC metadata.xml 253 BLAKE2B a1efbd3751efaa83ee173f557ec1c8a4497a90b60896cf5a7a07da40b4f94a7a299ca0385477e82b2f5e5dbdf9afa482ccbe21f35ef44214e9c451d764b65529 SHA512 8d59f413993268ca783f7407b676900bb2d964754bf705d4175e2bafbe058a52af74f3928e4bd84d292518f8cf13fab7051486ab7cdc61d02fae6e0188d44442
diff --git a/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.26.0-r1.ebuild b/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.26.0-r1.ebuild
new file mode 100644
index 000000000000..91bcc03e1c4c
--- /dev/null
+++ b/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.26.0-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit flag-o-matic gnome2
+
+DESCRIPTION="C++ bindings for gnome-vfs"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1"
+SLOT="1.1"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd"
+IUSE="doc examples"
+
+# glibmm dep is because build fails with older versions...
+RDEPEND="
+ >=gnome-base/gnome-vfs-2.8.1
+ >=dev-cpp/glibmm-2.12
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ if ! use doc; then
+ # documentation requires Doxygen and takes time
+ sed -i 's/^\(SUBDIRS =.*\)docs\(.*\)$/\1\2/' Makefile.in || \
+ die "sed Makefile.in failed"
+ fi
+
+ if ! use examples; then
+ # don't waste time building the examples
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || \
+ die "sed Makefile.in failed"
+ fi
+
+ append-cxxflags -std=c++11
+
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc ; then
+ dohtml -r docs/reference/html/*
+ fi
+
+ if use examples; then
+ find examples -type d -name '.deps' -exec rm -fr {} \; 2>/dev/null
+ cp -R examples "${ED}"/usr/share/doc/${PF}
+ fi
+}
diff --git a/dev-cpp/gnome-vfsmm/metadata.xml b/dev-cpp/gnome-vfsmm/metadata.xml
new file mode 100644
index 000000000000..996e7cacd217
--- /dev/null
+++ b/dev-cpp/gnome-vfsmm/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+</pkgmetadata>