summaryrefslogtreecommitdiff
path: root/dev-cpp/functional-plus
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/functional-plus')
-rw-r--r--dev-cpp/functional-plus/Manifest3
-rw-r--r--dev-cpp/functional-plus/functional-plus-0.2.22.ebuild50
-rw-r--r--dev-cpp/functional-plus/metadata.xml16
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-cpp/functional-plus/Manifest b/dev-cpp/functional-plus/Manifest
new file mode 100644
index 000000000000..be9f895678b8
--- /dev/null
+++ b/dev-cpp/functional-plus/Manifest
@@ -0,0 +1,3 @@
+DIST functional-plus-0.2.22.tar.gz 282821 BLAKE2B dd32e0c518d3b18dd7f31498579edb05cd8a73108c4720db560b48931ed50d8a1a970916d517d488188cdfd69d04d2a3bc6dbfe193b5b8adf114ee7a2938208c SHA512 399ff3012efd49e8617a0ae275e72bf13e87380e830f6ceb56f85fcda948d4ef252c5aa48f48f0a4a015874015d6e8ff442ac9395d523b4c946a01c17f2bd1b9
+EBUILD functional-plus-0.2.22.ebuild 1003 BLAKE2B e495c0f252e93d0840fb5e81ef681e94c4edcff5b8bd5c8ad3cd32402f77ccd7b273abc98a1e3495e86236d6f6337439fd77578569969eaf144b9af79e81625e SHA512 ad40320104b3d629ab960bcb08e58addd458f311e6fdcf230e129eba8e5a319326ad6b916ca4095e9fce9bef1b77e3cdb2d3c1c270daf52d80bdd37f65db54b7
+MISC metadata.xml 555 BLAKE2B afee8434dbc625843066f5c296366f671cd0f74a47db16e2d7764845a736d573b0a7da5c161421306ea493ea8e1e697db8cca838433f7e6257c696f364d78ea1 SHA512 f387279a3d8ecd5fa6e40d414ff73e8b8b8c36c28e21158d1f22d050730fee7ed26c3d9248c688a893da1fb8160010b6e14e7d10bc05ac55c161342c0b3fd0ae
diff --git a/dev-cpp/functional-plus/functional-plus-0.2.22.ebuild b/dev-cpp/functional-plus/functional-plus-0.2.22.ebuild
new file mode 100644
index 000000000000..38e0d9137331
--- /dev/null
+++ b/dev-cpp/functional-plus/functional-plus-0.2.22.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Dobiasd/FunctionalPlus.git"
+else
+ SRC_URI="https://github.com/Dobiasd/FunctionalPlus/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Functional Programming Library for C++"
+HOMEPAGE="
+ https://www.editgym.com/fplus-api-search/
+ https://github.com/Dobiasd/FunctionalPlus
+"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/doctest )"
+
+S="${WORKDIR}/FunctionalPlus-${PV}"
+
+fplus_test_wrapper() {
+ local BUILD_DIR="${WORKDIR}/${P}_build/test"
+ local CMAKE_USE_DIR="${S}/test"
+ $@
+}
+
+src_configure() {
+ cmake_src_configure
+ use test && fplus_test_wrapper cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use test && fplus_test_wrapper cmake_src_compile
+}
+
+src_test() {
+ fplus_test_wrapper cmake_src_test
+}
diff --git a/dev-cpp/functional-plus/metadata.xml b/dev-cpp/functional-plus/metadata.xml
new file mode 100644
index 000000000000..4dbdfbab0058
--- /dev/null
+++ b/dev-cpp/functional-plus/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lockalsash@gmail.com</email>
+ <name>Sv. Lockal</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/Dobiasd/FunctionalPlus/issues</bugs-to>
+ <remote-id type="github">Dobiasd/FunctionalPlus</remote-id>
+ </upstream>
+</pkgmetadata>