summaryrefslogtreecommitdiff
path: root/dev-cpp/elfio/elfio-3.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/elfio/elfio-3.10.ebuild')
-rw-r--r--dev-cpp/elfio/elfio-3.10.ebuild27
1 files changed, 0 insertions, 27 deletions
diff --git a/dev-cpp/elfio/elfio-3.10.ebuild b/dev-cpp/elfio/elfio-3.10.ebuild
deleted file mode 100644
index 18f8232d6cfc..000000000000
--- a/dev-cpp/elfio/elfio-3.10.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="ELF reader/producer header-only C++ library"
-HOMEPAGE="https://github.com/serge1/ELFIO"
-SRC_URI="https://github.com/serge1/${PN}/archive/Release_${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN^^}-Release_${PV}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-libs/boost )"
-
-src_configure() {
- local mycmakeargs=(
- -DELFIO_BUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}