summaryrefslogtreecommitdiff
path: root/dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0-r1.ebuild')
-rw-r--r--dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0-r1.ebuild b/dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0-r1.ebuild
new file mode 100644
index 000000000000..b3df053c1da1
--- /dev/null
+++ b/dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Modern C++ Parallel Task Programming"
+HOMEPAGE="https://cpp-taskflow.github.io"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${P}-do_not_compile_examples.patch
+ "${FILESDIR}"/${P}-fix_installation_path.patch
+)
+
+HTML_DOCS=( docs/. )
+
+src_install() {
+ cmake-utils_src_install
+
+ if $(use doc); then
+ einstalldocs
+ fi
+}