summaryrefslogtreecommitdiff
path: root/dev-cpp/cpp-httplib/cpp-httplib-0.15.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/cpp-httplib/cpp-httplib-0.15.3.ebuild')
-rw-r--r--dev-cpp/cpp-httplib/cpp-httplib-0.15.3.ebuild24
1 files changed, 23 insertions, 1 deletions
diff --git a/dev-cpp/cpp-httplib/cpp-httplib-0.15.3.ebuild b/dev-cpp/cpp-httplib/cpp-httplib-0.15.3.ebuild
index 64fb0aa6f65e..fb9e0f90ef7a 100644
--- a/dev-cpp/cpp-httplib/cpp-httplib-0.15.3.ebuild
+++ b/dev-cpp/cpp-httplib/cpp-httplib-0.15.3.ebuild
@@ -58,6 +58,28 @@ src_configure() {
multilib_src_test() {
cp -p -R --reflink=auto "${S}/test" ./test || die
- GTEST_FILTER='-*.*_Online' emake -C test \
+ local -a failing_tests=(
+ # Disable all online tests.
+ "*.*_Online"
+
+ # Fails on musl x86:
+ ServerTest.GetRangeWithMaxLongLength
+ ServerTest.GetStreamedWithTooManyRanges
+
+ # https://github.com/yhirose/cpp-httplib/issues/1798
+ # Filed by mgorny's testing, fails on openssl >=3.2:
+ SSLClientServerTest.ClientCertPresent
+ SSLClientServerTest.ClientEncryptedCertPresent
+ SSLClientServerTest.CustomizeServerSSLCtx
+ SSLClientServerTest.MemoryClientCertPresent
+ SSLClientServerTest.MemoryClientEncryptedCertPresent
+ SSLClientServerTest.TrustDirOptional
+ )
+
+ # Little dance to please the GTEST filter (join array using ":").
+ failing_tests_str="${failing_tests[@]}"
+ failing_tests_filter="${failing_tests_str// /:}"
+
+ GTEST_FILTER="-${failing_tests_filter}" emake -C test \
CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} -I."
}