summaryrefslogtreecommitdiff
path: root/dev-cpp/catch/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/catch/files')
-rw-r--r--dev-cpp/catch/files/catch-2.3.0-python-automagic.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-cpp/catch/files/catch-2.3.0-python-automagic.patch b/dev-cpp/catch/files/catch-2.3.0-python-automagic.patch
new file mode 100644
index 000000000000..c7fa4c6d22f6
--- /dev/null
+++ b/dev-cpp/catch/files/catch-2.3.0-python-automagic.patch
@@ -0,0 +1,25 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -36,7 +36,11 @@
+ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /ENTRY:wmainCRTStartup")
+ endif()
+
++find_package(PythonInterp)
+ if (BUILD_TESTING AND CATCH_BUILD_TESTING AND NOT_SUBPROJECT)
++ if (NOT PYTHONINTERP_FOUND)
++ message(FATAL_ERROR "Python not found, but required for tests")
++ endif()
+ add_subdirectory(projects)
+ endif()
+
+--- a/projects/CMakeLists.txt
++++ b/projects/CMakeLists.txt
+@@ -317,7 +317,7 @@
+ set_tests_properties(NoTest PROPERTIES PASS_REGULAR_EXPRESSION "No test cases matched")
+
+ # AppVeyor has a Python 2.7 in path, but doesn't have .py files as autorunnable
+-add_test(NAME ApprovalTests COMMAND python ${CATCH_DIR}/scripts/approvalTests.py $<TARGET_FILE:SelfTest>)
++add_test(NAME ApprovalTests COMMAND ${PYTHON_EXECUTABLE} ${CATCH_DIR}/scripts/approvalTests.py $<TARGET_FILE:SelfTest>)
+ set_tests_properties(ApprovalTests PROPERTIES FAIL_REGULAR_EXPRESSION "Results differed")
+
+ if (CATCH_USE_VALGRIND)