summaryrefslogtreecommitdiff
path: root/dev-cpp/benchmark/benchmark-1.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/benchmark/benchmark-1.9.0.ebuild')
-rw-r--r--dev-cpp/benchmark/benchmark-1.9.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-cpp/benchmark/benchmark-1.9.0.ebuild b/dev-cpp/benchmark/benchmark-1.9.0.ebuild
index 90c9239289bf..46af0a1dbe0f 100644
--- a/dev-cpp/benchmark/benchmark-1.9.0.ebuild
+++ b/dev-cpp/benchmark/benchmark-1.9.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_12 )
+PYTHON_COMPAT=( python3_{11,12} )
inherit cmake-multilib python-single-r1
@@ -15,7 +15,7 @@ SLOT="0/$(ver_cut 1)"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~x86"
IUSE="doc +exceptions libcxx libpfm lto test +tools"
RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+REQUIRED_USE="tools? ( ${PYTHON_REQUIRED_USE} )"
DEPEND="
libcxx? ( sys-libs/libcxx[${MULTILIB_USEDEP}] )