summaryrefslogtreecommitdiff
path: root/dev-cpp/aixlog/aixlog-1.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/aixlog/aixlog-1.4.0.ebuild')
-rw-r--r--dev-cpp/aixlog/aixlog-1.4.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-cpp/aixlog/aixlog-1.4.0.ebuild b/dev-cpp/aixlog/aixlog-1.4.0.ebuild
new file mode 100644
index 000000000000..b1164d6bbd11
--- /dev/null
+++ b/dev-cpp/aixlog/aixlog-1.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Header-only C++ logging library"
+HOMEPAGE="https://github.com/badaix/aixlog"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/badaix/aixlog.git"
+ EGIT_BRANCH="develop"
+else
+ SRC_URI="https://github.com/badaix/aixlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_EXAMPLE=OFF )
+
+ cmake_src_configure
+}