summaryrefslogtreecommitdiff
path: root/dev-build/libtool/libtool-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-build/libtool/libtool-9999.ebuild')
-rw-r--r--dev-build/libtool/libtool-9999.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-build/libtool/libtool-9999.ebuild b/dev-build/libtool/libtool-9999.ebuild
index 033495d8ee02..f25c4861a85e 100644
--- a/dev-build/libtool/libtool-9999.ebuild
+++ b/dev-build/libtool/libtool-9999.ebuild
@@ -96,11 +96,15 @@ src_configure() {
# to find a bash shell. if /bin/sh is bash, it uses that. this can
# cause problems for people who switch /bin/sh on the fly to other
# shells, so just force libtool to use /bin/bash all the time.
- export CONFIG_SHELL="${EPREFIX}"/bin/bash
-
# Do not bother hardcoding the full path to sed.
# Just rely on $PATH. bug #574550
+ export CONFIG_SHELL="${EPREFIX}"/bin/bash
export ac_cv_path_SED="$(basename "$(type -P sed)")"
+ export ac_cv_path_EGREP="$(basename "$(type -P grep)") -E"
+ export ac_cv_path_EGREP_TRADITIONAL="$(basename "$(type -P grep)") -E"
+ export ac_cv_path_FGREP="$(basename "$(type -P grep)") -F"
+ export ac_cv_path_GREP="$(basename "$(type -P grep)")"
+ export ac_cv_path_lt_DD="$(basename "$(type -P dd)")"
[[ ${CHOST} == *-darwin* ]] && local myconf="--program-prefix=g"