summaryrefslogtreecommitdiff
path: root/backup/rdup
diff options
context:
space:
mode:
Diffstat (limited to 'backup/rdup')
-rw-r--r--backup/rdup/Manifest3
-rw-r--r--backup/rdup/metadata.xml11
-rw-r--r--backup/rdup/rdup-1.1.15.ebuild41
3 files changed, 55 insertions, 0 deletions
diff --git a/backup/rdup/Manifest b/backup/rdup/Manifest
new file mode 100644
index 000000000000..13cb3ea1ee42
--- /dev/null
+++ b/backup/rdup/Manifest
@@ -0,0 +1,3 @@
+DIST rdup-1.1.15.tar.gz 333646 BLAKE2B 452cf4a4e6393ae56ffee4ebd3086af0606b03125f9af84590314516fa643fd4122d64a34e17d6a5b4bd7ac5921bb9f1fe3c312694015b90b91a85f9c48cd851 SHA512 e377ec29e0dacae306ee58c935c9738f32d177e1c2575e4fa3618d2753d248f2898633dde46da81410271205458ccf0d3d885e3eebc5f1948afc5cd9e99ce7c3
+EBUILD rdup-1.1.15.ebuild 856 BLAKE2B 8d279dc4921220c67da27f08e81ff932f6c5eaf4096ea1ab17e83e45a12895a14b32c8f34e10d9bc531b5b5a02d4e0be5624f0361628bf394081a4a86f8fd77d SHA512 b17d5ceab2aa7ead80cd792473b90390922976b708f48ee747dd5b3d84578cb065e6e93851e277f4ab3cd1b39037a2d441a9949cdd73a71a86044e0a45e1acbd
+MISC metadata.xml 325 BLAKE2B 884b9307d33bc2a05e23db61a7f39c620df3147241b851254747e19bd5362c9bed0c3db8d5b4e7da483374acc6ad28e7128a7c093da677d4ce94f5d24921bdbd SHA512 73d0a20ad97d9e9c26f10252fb7d50c93b2c5d07df8eceb8f97796758341c884bdd75ea7707f5f0645d430348af6669595612c662dd019d355fa9f366f6d44fd
diff --git a/backup/rdup/metadata.xml b/backup/rdup/metadata.xml
new file mode 100644
index 000000000000..9f9793a7335b
--- /dev/null
+++ b/backup/rdup/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">miekg/rdup</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/backup/rdup/rdup-1.1.15.ebuild b/backup/rdup/rdup-1.1.15.ebuild
new file mode 100644
index 000000000000..a0188659a094
--- /dev/null
+++ b/backup/rdup/rdup-1.1.15.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils autotools
+
+DESCRIPTION="Generate a file list suitable for full or incremental backups"
+HOMEPAGE="https://github.com/miekg/rdup/releases"
+SRC_URI="https://github.com/miekg/rdup/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug test"
+
+RDEPEND="
+ app-arch/libarchive
+ dev-libs/glib:2
+ dev-libs/libpcre
+ dev-libs/nettle"
+DEPEND="${RDEPEND}
+ test? ( dev-util/dejagnu )"
+
+src_prepare() {
+ default_src_prepare
+ sed -i -e 's/ -Werror//' GNUmakefile.in || die "Failed to fix Makefile"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_test() {
+ if use debug; then
+ ewarn "Test phase skipped, as it is known to fail with USE=\"debug\"."
+ else
+ default_src_test
+ fi
+}