summaryrefslogtreecommitdiff
path: root/backup/pdumpfs
diff options
context:
space:
mode:
Diffstat (limited to 'backup/pdumpfs')
-rw-r--r--backup/pdumpfs/Manifest5
-rw-r--r--backup/pdumpfs/files/pdumpfs-in.patch40
-rw-r--r--backup/pdumpfs/files/pdumpfs-test.patch12
-rw-r--r--backup/pdumpfs/metadata.xml18
-rw-r--r--backup/pdumpfs/pdumpfs-1.3-r2.ebuild47
5 files changed, 122 insertions, 0 deletions
diff --git a/backup/pdumpfs/Manifest b/backup/pdumpfs/Manifest
new file mode 100644
index 000000000000..a68091d6e62c
--- /dev/null
+++ b/backup/pdumpfs/Manifest
@@ -0,0 +1,5 @@
+AUX pdumpfs-in.patch 977 BLAKE2B 5be9f88f6af0dc051c856da71c4cb4fc3d52f610ec0cedb0364b0d59d01925bcda9ab7c5872c0fe87e8aa9ba07a4d284adb90b382d6b92b480aa64cce1a4b00f SHA512 3d45d5ecbf2e3af71ae80de28c8cedc46b5ea2f7d0e9f6ea58c4154e477db8375f21587ebc4cade04b353e5a0552620790a0f8ea13d9f8151b4236e8e2489ee9
+AUX pdumpfs-test.patch 392 BLAKE2B 99b04a1f9667e5996afc294de54eca4d45d51ca36103f661a9c576a823faa85b1fd215e27ae6d1f2d9c02e696f55fceb9b00e55778d56bad0e5560d40aa18a00 SHA512 b7647f51acb30cfc86e80cf5eb5e6d7fa84c6b3ba3c1e6246468baca7835bd08a6d3f3e70dbb55a2c6ef0ffe67b4d10dd78b5a4673ff636c8da74e64f7b827fa
+DIST pdumpfs-1.3.tar.gz 68210 BLAKE2B ab5428c0f12ac289ef6efb5ae1b1ebcb047ce48183a36423d6f4b80d2d55da07b6e346e8ebd0ccd6eb85ae132c4367bd806c8106abeb681a9fa6ebffbaef1075 SHA512 1299676982f1981aa55f0601f361ec24ac119067f5ecbbeebcf9f41ccd69df2f18a07ae5a6e77f30ca7606ee49ecfa516d6066a07c1edbb4d4796f34f02508c3
+EBUILD pdumpfs-1.3-r2.ebuild 886 BLAKE2B 0f8e1b67227771c8cb377468cef7141f726dfa9c69422d04dc3fc968f800b15f66b2c6810a1ea9eb0ab2f1894f35aad84b0269c92bf2001ac188098f28c6c626 SHA512 dccd98ec4b5524c5a960ec5d38d4669f0e15346e0bb65bb3e14fde696b43f45cbbe1882fbda5922edd241a8f7b0c49161f362c2e6435ecec9fc6fffe127ee52d
+MISC metadata.xml 659 BLAKE2B 2fb28583b174d69031ec454a7d8e45876eceada6d5a7c4a150d079a67009120f67e8cab6ac772d2c0968289544e08753a389ccb6d19854998e1d98deee9a6bff SHA512 ad8d61826ef10df3dbb0765ca6f5c020044ce015663f4b96dde61e92fca360866d72fb84751da465c0659956b6d849a565966ae444969c6a6754a5d49a74eaab
diff --git a/backup/pdumpfs/files/pdumpfs-in.patch b/backup/pdumpfs/files/pdumpfs-in.patch
new file mode 100644
index 000000000000..cddfb995918a
--- /dev/null
+++ b/backup/pdumpfs/files/pdumpfs-in.patch
@@ -0,0 +1,40 @@
+patch by proxy maintainer, P. Healy, April 2015
+# Bug 509960
+--- pdumpfs.in_orig 2004-12-21 02:43:12.000000000 +0000
++++ pdumpfs.in 2015-04-01 10:58:22.671131947 +0100
+@@ -48,7 +48,7 @@
+ #
+
+ require 'find'
+-require 'ftools'
++require 'fileutils'
+ require 'getoptlong'
+ require 'date'
+
+@@ -868,7 +868,7 @@
+ today = File.join(dest, datedir(start_time), base)
+
+ File.umask(0077)
+- File.mkpath(today) unless @dry_run
++ FileUtils.mkpath(today) unless @dry_run
+ if latest
+ update_snapshot(src, latest, today)
+ else
+@@ -1018,7 +1018,7 @@
+
+ case type
+ when "directory"
+- File.mkpath(today)
++ FileUtils.mkpath(today)
+ when "unchanged"
+ File.force_link(latest, today)
+ when "updated"
+@@ -1089,7 +1089,7 @@
+
+ case type
+ when "directory"
+- File.mkpath(t)
++ FileUtils.mkpath(t)
+ when "new_file"
+ copy(s, t)
+ when "symlink"
diff --git a/backup/pdumpfs/files/pdumpfs-test.patch b/backup/pdumpfs/files/pdumpfs-test.patch
new file mode 100644
index 000000000000..e81e8b0f2d8a
--- /dev/null
+++ b/backup/pdumpfs/files/pdumpfs-test.patch
@@ -0,0 +1,12 @@
+patch by proxy maintainer, P. Healy, April 2015
+# Bug 509960
+--- tests/pdumpfs-test_orig 2004-08-10 07:54:28.000000000 +0100
++++ tests/pdumpfs-test 2015-04-01 11:24:35.948633870 +0100
+@@ -17,6 +17,7 @@
+
+ ../pdumpfs src dest > tmp.log || exit 1
+ diff -r src dest/$today/src || exit 1
++mkdir -p dest/$yesterday && rmdir dest/$yesterday
+ mv dest/$today dest/$yesterday
+
+ echo update > src/foo
diff --git a/backup/pdumpfs/metadata.xml b/backup/pdumpfs/metadata.xml
new file mode 100644
index 000000000000..02211b3e08f7
--- /dev/null
+++ b/backup/pdumpfs/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lmiphay@gmail.com</email>
+ <name>Paul Healy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+<longdescription>
+pdumpfs is a simple daily backup system similar to Plan9's dumpfs which
+preserves every daily snapshot. pdumpfs is written in Ruby. You can access
+the past snapshots at any time for retrieving a certain day's file. Let's
+backup your home directory with pdumpfs!
+</longdescription>
+</pkgmetadata>
diff --git a/backup/pdumpfs/pdumpfs-1.3-r2.ebuild b/backup/pdumpfs/pdumpfs-1.3-r2.ebuild
new file mode 100644
index 000000000000..527828394d33
--- /dev/null
+++ b/backup/pdumpfs/pdumpfs-1.3-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A daily backup system similar to Plan9's dumpfs"
+HOMEPAGE="http://0xcc.net/pdumpfs/"
+SRC_URI="http://0xcc.net/pdumpfs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="l10n_ja"
+
+DEPEND=">=dev-lang/ruby-2.0.0_p598"
+
+src_prepare() {
+ # Bug #509960
+ epatch "${FILESDIR}/${PN}-in.patch" \
+ "${FILESDIR}/${PN}-test.patch"
+}
+
+src_compile() {
+ emake pdumpfs
+}
+
+src_test() {
+ # RUBYOPT=-rauto_gem without rubygems installed will cause ruby to fail, bug #158455 and #163473.
+ export RUBYOPT="${GENTOO_RUBYOPT}"
+ emake check
+}
+
+src_install() {
+ dobin pdumpfs
+
+ doman man/man8/pdumpfs.8
+ dohtml -r doc/*
+
+ if use l10n_ja; then
+ insinto /usr/share/man/ja/man8
+ doins man/ja/man8/pdumpfs.8
+ fi
+
+ dodoc ChangeLog README
+}