summaryrefslogtreecommitdiff
path: root/backup/holland-backup-pgdump/holland-backup-pgdump-1.0.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'backup/holland-backup-pgdump/holland-backup-pgdump-1.0.10.ebuild')
-rw-r--r--backup/holland-backup-pgdump/holland-backup-pgdump-1.0.10.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/backup/holland-backup-pgdump/holland-backup-pgdump-1.0.10.ebuild b/backup/holland-backup-pgdump/holland-backup-pgdump-1.0.10.ebuild
new file mode 100644
index 000000000000..63609d1a9966
--- /dev/null
+++ b/backup/holland-backup-pgdump/holland-backup-pgdump-1.0.10.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Holland pgdump Plugin"
+HOMEPAGE="http://www.hollandbackup.org/"
+
+MY_P="${P%%-*}-${P##*-}"
+
+SRC_URI="http://hollandbackup.org/releases/stable/${PV%.*}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ ~app-backup/holland-lib-common-${PV}[${PYTHON_USEDEP}]
+ dev-python/psycopg[${PYTHON_USEDEP}]
+"
+PDEPEND="~app-backup/holland-${PV}[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}/plugins/${PN//-/.}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ keepdir /etc/holland
+ keepdir /etc/holland/providers
+
+ insinto /etc/holland/providers
+ doins "${S}"/../../config/providers/${PN##*-}.conf
+}