summaryrefslogtreecommitdiff
path: root/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/vimoutliner/vimoutliner-0.4.0_p20180301.ebuild')
-rw-r--r--app-vim/vimoutliner/vimoutliner-0.4.0_p20180301.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301.ebuild b/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301.ebuild
deleted file mode 100644
index 693542279762..000000000000
--- a/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1 vim-plugin vcs-snapshot
-
-# Commit Date: 1 Mar 2018
-COMMIT="4f12628247940d98eedd594961695dc504261058"
-
-DESCRIPTION="Vim plugin for easy and fast outlining"
-HOMEPAGE="https://github.com/vimoutliner/vimoutliner"
-SRC_URI="https://github.com/vimoutliner/vimoutliner/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-KEYWORDS="~amd64 ~x86"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-VIM_PLUGIN_HELPFILES="vimoutliner"
-VIM_PLUGIN_MESSAGES="filetype"
-
-RDEPEND="dev-python/autopep8"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- default
-
- sed -i -e '1s:^:#!/usr/bin/python\n:' vimoutliner/scripts/otl2latex/otl2latex.py
- find "${S}" -type f -exec chmod a+r {} \; || die
-}
-
-src_compile() {
- local pyscript _pyscript
- for pyscript in $(find "${S}" -type f -name \*.py); do
- _pyscript=$(basename "${pyscript}")
- [ ${_pyscript} == "otl.py" ] && continue
- python_fix_shebang -q "${pyscript}"
- done
-}