summaryrefslogtreecommitdiff
path: root/app-vim/vimcalc/vimcalc-1.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/vimcalc/vimcalc-1.3-r2.ebuild')
-rw-r--r--app-vim/vimcalc/vimcalc-1.3-r2.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/app-vim/vimcalc/vimcalc-1.3-r2.ebuild b/app-vim/vimcalc/vimcalc-1.3-r2.ebuild
deleted file mode 100644
index 151fa8451f7a..000000000000
--- a/app-vim/vimcalc/vimcalc-1.3-r2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1 vim-plugin
-
-DESCRIPTION="vim plugin: provides an interactive calculator inside vim"
-HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=3329"
-SRC_URI="https://www.vim.org/scripts/download_script.php?src_id=15317 -> ${P}.zip"
-LICENSE="vim"
-KEYWORDS="amd64 x86"
-
-VIM_PLUGIN_HELPFILES="vimcalc"
-
-DEPEND="
- app-arch/unzip
- ${PYTHON_DEPS}"
-
-RDEPEND="
- || ( app-editors/vim[python,${PYTHON_USEDEP}] app-editors/gvim[python,${PYTHON_USEDEP}] )
- ${PYTHON_DEPS}"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-S="${WORKDIR}/${PN}-v${PV}"
-
-src_prepare() {
- # Remove .DS_Store files that should not be installed
- find -type f -name '.DS*' -delete || die
-}
-
-src_test() {
- cd plugin || die
- "${PYTHON}" tests.py || die "Tests failed"
-}
-
-src_install() {
- rm plugin/tests.py || die
- vim-plugin_src_install
-}