summaryrefslogtreecommitdiff
path: root/app-vim/slimv/slimv-0.9.12-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/slimv/slimv-0.9.12-r1.ebuild')
-rw-r--r--app-vim/slimv/slimv-0.9.12-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-vim/slimv/slimv-0.9.12-r1.ebuild b/app-vim/slimv/slimv-0.9.12-r1.ebuild
new file mode 100644
index 000000000000..1d601bfbaeef
--- /dev/null
+++ b/app-vim/slimv/slimv-0.9.12-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 vim-plugin vcs-snapshot
+
+DESCRIPTION="vim plugin: aid Lisp development by providing a SLIME-like Lisp and Clojure REPL"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2531 https://github.com/kovisoft/slimv"
+SRC_URI="https://bitbucket.org/kovisoft/${PN}/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+LICENSE="public-domain"
+KEYWORDS="amd64 x86"
+
+RDEPEND="|| ( app-editors/vim[python,${PYTHON_USEDEP}] app-editors/gvim[python,${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}
+ || (
+ dev-lisp/clisp
+ dev-lang/clojure
+ dev-lisp/abcl
+ dev-lisp/clozurecl
+ dev-lisp/ecls
+ dev-lisp/sbcl
+ )"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ # remove emacs related files
+ rm -r slime swank-clojure || die
+}