summaryrefslogtreecommitdiff
path: root/app-vim/pydiction/pydiction-1.2.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/pydiction/pydiction-1.2.3-r2.ebuild')
-rw-r--r--app-vim/pydiction/pydiction-1.2.3-r2.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/app-vim/pydiction/pydiction-1.2.3-r2.ebuild b/app-vim/pydiction/pydiction-1.2.3-r2.ebuild
deleted file mode 100644
index a0972c26972c..000000000000
--- a/app-vim/pydiction/pydiction-1.2.3-r2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit vim-plugin python-r1
-
-DESCRIPTION="vim plugin: tab-complete your Python code"
-HOMEPAGE="https://rkulla.github.io/pydiction/"
-SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.zip"
-
-LICENSE="vim"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="app-arch/unzip"
-RDEPEND="${PYTHON_DEPS}"
-
-S="${WORKDIR}/${PN}-master"
-
-src_install() {
- # Rename pydiction script.
- mv "${PN}.py" "${PN}" || die
-
- # We're going to remove those files in a second
- # otherwise they're installed by Portage.
- local pyfiles=( complete-dict "${PN}" )
- insinto "/usr/share/${P}"
- doins complete-dict
-
- # pydiction is treated a singular script that lives on its own.
- python_foreach_impl python_doscript "${PN}"
- rm -v "${pyfiles[@]}" || die
-
- vim-plugin_src_install
-}