summaryrefslogtreecommitdiff
path: root/app-vim/perl-support/perl-support-5.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/perl-support/perl-support-5.3.2.ebuild')
-rw-r--r--app-vim/perl-support/perl-support-5.3.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-vim/perl-support/perl-support-5.3.2.ebuild b/app-vim/perl-support/perl-support-5.3.2.ebuild
new file mode 100644
index 000000000000..a5cfb0273bf2
--- /dev/null
+++ b/app-vim/perl-support/perl-support-5.3.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Perl-IDE - Write and run Perl scripts using menus and hotkeys"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=556"
+LICENSE="GPL-2 GPL-2+"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+VIM_PLUGIN_HELPFILES="perlsupport.txt"
+
+RDEPEND="
+ dev-perl/Perl-Tags
+ dev-perl/Perl-Critic"
+
+src_prepare() {
+ # Don't set tabstop and shiftwidth
+ sed -i '/=4/s/^/"/' ftplugin/perl.vim || die
+}
+
+src_install() {
+ dodoc ${PN}/doc/{ChangeLog,perl-hot-keys.pdf}
+ rm -r ${PN}/doc/ || die
+
+ vim-plugin_src_install
+}