summaryrefslogtreecommitdiff
path: root/app-vim/neocomplcache
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/neocomplcache')
-rw-r--r--app-vim/neocomplcache/Manifest4
-rw-r--r--app-vim/neocomplcache/metadata.xml11
-rw-r--r--app-vim/neocomplcache/neocomplcache-7.1-r1.ebuild19
-rw-r--r--app-vim/neocomplcache/neocomplcache-7.1.ebuild14
4 files changed, 48 insertions, 0 deletions
diff --git a/app-vim/neocomplcache/Manifest b/app-vim/neocomplcache/Manifest
new file mode 100644
index 000000000000..60743b07dc30
--- /dev/null
+++ b/app-vim/neocomplcache/Manifest
@@ -0,0 +1,4 @@
+DIST neocomplcache-7.1.tar.bz2 73724 BLAKE2B 16c04762164c6b086b4683bba71073eaed0a21b003f7d42bb7e4d5a7a1767f982b80840c229402312622e2f9b3f5c9a0759bfc8ece3b320ab38d94c406453cf9 SHA512 1ed17243722055a08bfda6b3e5524870d55377dd5998cbc5677f673974eebf5ee4019975e6b66c12c8ce5ff804d5c1512e69b7f53f56c1bb6f87638025a3210b
+EBUILD neocomplcache-7.1-r1.ebuild 415 BLAKE2B 1befd69348909cf5b299a312208ee5f0e26a58489fd9f11e1a02859c4ed713c43803888c0342a56a06487e21ac348e3cb8900f6b9052e5fa16a3c97569a890f5 SHA512 d252c5978d7e51298c84f71a5e7b50fea7a31f7b9968b94d9c6f23480573ce9f5b39075ff061457e91df9d0e56f7612fe15b2f3008fbc59467d34edf3a2c97e8
+EBUILD neocomplcache-7.1.ebuild 336 BLAKE2B 4d96faaf4563a59e747278b96d9bc20c68acfc60f9218a8f7bbebaff169499ed229b7a59a257396736458c084179c3ee0bdaab1e766904596d5bbb12584daafa SHA512 b8b71334c04e4cca889fbd3682dcb9d9c8220ccf0c8a1904f8413dc79e85d0dd540be9f25801279f8a35714d8760f474db555acc0f8550971c651fa6de7b01e8
+MISC metadata.xml 349 BLAKE2B 7c4db2d8de75be71de1de92126b543ad0a522c95d23c3a97422c02ca8dbc9dcf1211af15b32809ea4d39be09e8c89e323ed1f15cf851fc4c877fa34611b5faee SHA512 2fbc0b0ecbd013d0c7dbc2e4cfe560d46beecb157052c05635c25d9ebb836a4969879b121a07c429699d454350ddb2aaa97cdcc0e9a5e36d52eea2964df392be
diff --git a/app-vim/neocomplcache/metadata.xml b/app-vim/neocomplcache/metadata.xml
new file mode 100644
index 000000000000..077f19f1d9ba
--- /dev/null
+++ b/app-vim/neocomplcache/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">vim-scripts/neocomplcache</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/neocomplcache/neocomplcache-7.1-r1.ebuild b/app-vim/neocomplcache/neocomplcache-7.1-r1.ebuild
new file mode 100644
index 000000000000..ea0fa5e98735
--- /dev/null
+++ b/app-vim/neocomplcache/neocomplcache-7.1-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: ultimate auto completion system"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2620"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+
+ mv autoload/vital.vim "autoload/${PN}vital.vim" || die
+}
diff --git a/app-vim/neocomplcache/neocomplcache-7.1.ebuild b/app-vim/neocomplcache/neocomplcache-7.1.ebuild
new file mode 100644
index 000000000000..2e6bd637060e
--- /dev/null
+++ b/app-vim/neocomplcache/neocomplcache-7.1.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: ultimate auto completion system"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2620"
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"