summaryrefslogtreecommitdiff
path: root/app-vim/fluxbox-syntax/fluxbox-syntax-1.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/fluxbox-syntax/fluxbox-syntax-1.5.ebuild')
-rw-r--r--app-vim/fluxbox-syntax/fluxbox-syntax-1.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-vim/fluxbox-syntax/fluxbox-syntax-1.5.ebuild b/app-vim/fluxbox-syntax/fluxbox-syntax-1.5.ebuild
new file mode 100644
index 000000000000..082606e60e31
--- /dev/null
+++ b/app-vim/fluxbox-syntax/fluxbox-syntax-1.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: fluxbox files syntax and indent"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=679"
+LICENSE="vim"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+RDEPEND="${RDEPEND} >=app-vim/genindent-1.0"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting and indent settings for fluxbox
+menus and similar files. Upstream don't provide us with an ftdetect file,
+but a simple one has been created for you by this ebuild. You can manually
+set the filetype using :set filetype=fluxbox if necessary."
+
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # no ftdetect file provided. lame...
+ mkdir ftdetect
+ echo "au BufNewFile,BufRead /*/*fluxbox/*menu set filetype=fluxbox" \
+ > ftdetect/fluxbox.vim
+}