summaryrefslogtreecommitdiff
path: root/app-vim/easytags
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/easytags')
-rw-r--r--app-vim/easytags/Manifest5
-rw-r--r--app-vim/easytags/easytags-3.11-r1.ebuild50
-rw-r--r--app-vim/easytags/easytags-3.11.ebuild40
-rw-r--r--app-vim/easytags/files/easytags-3.11-fix-ctags-detection.patch54
-rw-r--r--app-vim/easytags/metadata.xml11
5 files changed, 0 insertions, 160 deletions
diff --git a/app-vim/easytags/Manifest b/app-vim/easytags/Manifest
deleted file mode 100644
index 9f6c9c6edd1e..000000000000
--- a/app-vim/easytags/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX easytags-3.11-fix-ctags-detection.patch 2964 BLAKE2B eafaddd9877d8732eeace0197ab29cedba38a89a1f7c4e1fb2192cb075bc7a4541e6a5e5448a8944a7f6a0b47fb1cd481035529d6b11d5508df35089f2e85865 SHA512 f3ef6cfce5cbbebc4d33fc5f6fe0b7df037c9ec80da6f4a2b29bccb15e00b385719e654238f6becea1372900ac5f9e5e6d6af481537dde12c03cda24ee49e674
-DIST easytags-3.11.tar.gz 40572 BLAKE2B a6b228743f493bd467aff6685b6799de7e4862d384e14c81a084d7a211cf165d62cf902415a3c98a69858eded64c606bd4565f6e0c43fab7c078ba81d0ec5217 SHA512 9c1985a02b2718315d825ed29c06cbf78050e693893a9a7530a774031cbe9e6a27ee1dc91878950a1fbcaf7ea685faeb799d1e5b218b9ce25718783409f66130
-EBUILD easytags-3.11-r1.ebuild 1224 BLAKE2B d1784173bec8c978278e59586254b2bf6c9eaa9ac9ca744ff448eef65ae23f16d95476abd31d542ffdb2edbef70856142cc156bbb883bc57bfa93db6689fb370 SHA512 f1161fdfce9aa8ca733b25bb3ddcc187957e989b3b256fecdc4d314daa57e3b0979294d3ed2ad047748bbea48f573017531ba68df8270573e47cd4c2514760eb
-EBUILD easytags-3.11.ebuild 996 BLAKE2B c3211f023786914dc5d9c9f76cff7295cc8c3ead593438d74cb31565aee0f5c0a7057a6d2b3581d63a1bbcc2d2e5a70add77b2e84e3e78d7b9cab5478b3942f9 SHA512 c351e922c7d4656a1d92e2aaed798b125b40bee89a7e4d758ba0ea197a204b4905d5d8f017dcf5d781ee865350c68fddc2814a856ef3f16abf404486595274a8
-MISC metadata.xml 342 BLAKE2B 5e7e191544a04bc4ae28e482deef1c44c8ee11f6afe01d9ed6b138364f771411e341b5827e92bdfeae1edffdc166979c72a53034886530b0cdb55e34d9c2ce6e SHA512 0f4fbbedc023ccccc74ef8e020c3a90a0ccb0184164a52dd733699c5d4bf729d09478ea87fda093197679f7b44b3c1b64d3c64845d91d3fb92f9e3a1eab8fc78
diff --git a/app-vim/easytags/easytags-3.11-r1.ebuild b/app-vim/easytags/easytags-3.11-r1.ebuild
deleted file mode 100644
index cbd424d4f07a..000000000000
--- a/app-vim/easytags/easytags-3.11-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-
-inherit python-single-r1 vim-plugin
-
-DESCRIPTION="vim plugin: automated tag file generation and syntax highlighting"
-HOMEPAGE="http://peterodding.com/code/vim/easytags/"
-SRC_URI="https://github.com/xolox/vim-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- app-vim/vim-misc
- dev-util/ctags"
-
-VIM_PLUGIN_HELPFILES="${PN}.txt"
-
-S="${WORKDIR}/vim-${P}"
-
-PATCHES=( "${FILESDIR}/${P}-fix-ctags-detection.patch" )
-
-src_prepare() {
- default
- rm addon-info.json INSTALL.md README.md || die
-}
-
-src_install() {
- vim-plugin_src_install
-
- fperms 755 /usr/share/vim/vimfiles/misc/easytags/{normalize-tags,why-so-slow}.py
-
- # fix scripts
- local f
- for f in $(find "${ED}" -type f -name \*.py); do
- ebegin "Fixing $(basename ${f})"
- if [[ $f =~ highlight.py ]]; then
- sed -e '1 i\#!/usr/bin/env python3' -i "${f}" || die "can't sed patch ${f}"
- fi
- 2to3 -w -n --no-diffs "${f}" >& /dev/null || die "can't convert ${f} to Python 3"
- python_fix_shebang -q -f "${f}"
- eend $?
- done
-}
diff --git a/app-vim/easytags/easytags-3.11.ebuild b/app-vim/easytags/easytags-3.11.ebuild
deleted file mode 100644
index 3b3fa9986ce5..000000000000
--- a/app-vim/easytags/easytags-3.11.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1 vim-plugin
-
-DESCRIPTION="vim plugin: automated tag file generation and syntax highlighting"
-HOMEPAGE="http://peterodding.com/code/vim/easytags/"
-SRC_URI="https://github.com/xolox/vim-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-KEYWORDS="amd64 x86"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- >=app-vim/vim-misc-1.17.6
- dev-util/ctags"
-
-VIM_PLUGIN_HELPFILES="${PN}.txt"
-
-S="${WORKDIR}/vim-${P}"
-
-PATCHES=( "${FILESDIR}/${P}-fix-ctags-detection.patch" )
-
-src_prepare() {
- default
- # remove unnecessary files
- rm addon-info.json INSTALL.md README.md || die
-}
-
-src_install() {
- vim-plugin_src_install
-
- # fix scripts
- fperms 755 /usr/share/vim/vimfiles/misc/easytags/{normalize-tags,why-so-slow}.py
- python_fix_shebang "${ED}"/usr/share/vim/vimfiles/misc/easytags/{normalize-tags,why-so-slow}.py
-}
diff --git a/app-vim/easytags/files/easytags-3.11-fix-ctags-detection.patch b/app-vim/easytags/files/easytags-3.11-fix-ctags-detection.patch
deleted file mode 100644
index 56b24dfe406f..000000000000
--- a/app-vim/easytags/files/easytags-3.11-fix-ctags-detection.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From f5746bdfd9942b00c349e53f3f4917ae73bb6797 Mon Sep 17 00:00:00 2001
-From: Mathias Andersson <wraul@dbox.se>
-Date: Thu, 24 Dec 2015 14:24:34 +0100
-Subject: [PATCH] Fix detection of Universal Ctags.
-
-Recently Universal Ctags changed version from 'Development' to '0.0.0'
-which broke the detection.
----
- autoload/xolox/easytags.vim | 32 +++++++++++++++++++-------------
- 1 file changed, 19 insertions(+), 13 deletions(-)
-
-diff --git a/autoload/xolox/easytags.vim b/autoload/xolox/easytags.vim
-index d0dec21..3c85e6a 100644
---- a/autoload/xolox/easytags.vim
-+++ b/autoload/xolox/easytags.vim
-@@ -78,19 +78,25 @@ function! xolox#easytags#check_ctags_compatible(name, min_version) " {{{2
- call xolox#misc#msg#debug("easytags.vim %s: Command '%s' returned nonzero exit code %i!", g:xolox#easytags#version, a:name, result['exit_code'])
- else
- " Extract the version number from the output.
-- let pattern = '\(Exuberant\|Universal\) Ctags \zs\(\d\+\(\.\d\+\)*\|Development\)'
-- let g:easytags_ctags_version = matchstr(get(result['stdout'], 0, ''), pattern)
-- " Deal with development builds.
-- if g:easytags_ctags_version == 'Development'
-- call xolox#misc#msg#debug("easytags.vim %s: Assuming development build is compatible ..", g:xolox#easytags#version, a:name)
-- return 1
-- endif
-- " Make sure the version is compatible.
-- if xolox#misc#version#at_least(a:min_version, g:easytags_ctags_version)
-- call xolox#misc#msg#debug("easytags.vim %s: Version is compatible! :-)", g:xolox#easytags#version)
-- return 1
-- else
-- call xolox#misc#msg#debug("easytags.vim %s: Version is not compatible! :-(", g:xolox#easytags#version)
-+ let pattern = '\(\w\+\) Ctags \(\d\+\(\.\d\+\)*\|Development\)'
-+ let match = matchlist(get(result['stdout'], 0, ''), pattern)
-+ let g:easytags_ctags_fork = match[1]
-+ let g:easytags_ctags_version = match[2]
-+ if g:easytags_ctags_fork != '' && g:easytags_ctags_version != ''
-+ call xolox#misc#msg#debug("easytags.vim %s: Detected %s Ctags %s", g:xolox#easytags#version, g:easytags_ctags_fork, g:easytags_ctags_version)
-+ if g:easytags_ctags_fork == 'Universal'
-+ " All versions should be compatible.
-+ call xolox#misc#msg#debug("easytags.vim %s: Assuming all versions is compatible ..", g:xolox#easytags#version)
-+ return 1
-+ elseif g:easytags_ctags_fork == 'Exuberant'
-+ " Make sure the version is compatible.
-+ if xolox#misc#version#at_least(a:min_version, g:easytags_ctags_version)
-+ call xolox#misc#msg#debug("easytags.vim %s: Version is compatible! :-)", g:xolox#easytags#version)
-+ return 1
-+ else
-+ call xolox#misc#msg#debug("easytags.vim %s: Version is not compatible! :-(", g:xolox#easytags#version)
-+ endif
-+ endif
- endif
- endif
- call xolox#misc#msg#debug("easytags.vim %s: Standard output of command: %s", g:xolox#easytags#version, string(result['stdout']))
diff --git a/app-vim/easytags/metadata.xml b/app-vim/easytags/metadata.xml
deleted file mode 100644
index f13cee8dc033..000000000000
--- a/app-vim/easytags/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>vim@gentoo.org</email>
- <name>Gentoo Vim Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">xolox/vim-easytags</remote-id>
- </upstream>
-</pkgmetadata>