summaryrefslogtreecommitdiff
path: root/app-vim/bufexplorer/bufexplorer-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/bufexplorer/bufexplorer-9999.ebuild')
-rw-r--r--app-vim/bufexplorer/bufexplorer-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/bufexplorer/bufexplorer-9999.ebuild b/app-vim/bufexplorer/bufexplorer-9999.ebuild
new file mode 100644
index 000000000000..e285e23f86cd
--- /dev/null
+++ b/app-vim/bufexplorer/bufexplorer-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/jlanzarotta/bufexplorer.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/jlanzarotta/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: easily browse vim buffers"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=42 https://github.com/jlanzarotta/bufexplorer"
+LICENSE="BSD"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+ rm LICENSE README.md || die
+}