summaryrefslogtreecommitdiff
path: root/app-text
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/Manifest.gzbin49590 -> 49600 bytes
-rw-r--r--app-text/editorconfig-core-c/Manifest4
-rw-r--r--app-text/editorconfig-core-c/editorconfig-core-c-0.12.5.ebuild43
-rw-r--r--app-text/editorconfig-core-c/editorconfig-core-c-0.12.6.ebuild2
4 files changed, 2 insertions, 47 deletions
diff --git a/app-text/Manifest.gz b/app-text/Manifest.gz
index f6727f75e329..85f66db3b306 100644
--- a/app-text/Manifest.gz
+++ b/app-text/Manifest.gz
Binary files differ
diff --git a/app-text/editorconfig-core-c/Manifest b/app-text/editorconfig-core-c/Manifest
index 25ba75848107..398ae18a9d17 100644
--- a/app-text/editorconfig-core-c/Manifest
+++ b/app-text/editorconfig-core-c/Manifest
@@ -1,5 +1,3 @@
-DIST editorconfig-core-c-0.12.5.tar.gz 72272 BLAKE2B 044723047f8bc6ed0a4b3c5defbc43a0192edd0997dbaf9e9be6027d47f0d09c2bf4ba8141dda67ba541657a6c462afb86bb575a0eee586cf9a45581a5ff2017 SHA512 7d54c8c1ade8ecef5dc8f35e006f0e226455b7ed9541442a846bbebc26765e92abbbb29b991748164015bcfaff8764a0ac007e4384e163678a2922f7ca6b2e03
DIST editorconfig-core-c-0.12.6.tar.gz 76525 BLAKE2B 2ffad6b22d72bd23eca9f0f1704d279323328e01b72a4a18a7181c998f088d7f8c0bb93549d8071e6723b8294b628fe6d1b503de7434be45770a2be9127c1cab SHA512 7cf69ed48c0d28694fc1f54cd8ae89202a3f0a13b5302fd316f50d0f99a606f54af9709874f0da75ad11ab6f4cc36edacb4cd8639717d44842a309140be3a968
-EBUILD editorconfig-core-c-0.12.5.ebuild 1011 BLAKE2B 36c5dd06e06c4b1ccac9f514e7211788ef3c92b8bdb59ac6bf123f81712b879c9366ed35fa9b32921ee3112db203be8f441c0df225b4f78bdf2a90c970a2691c SHA512 86bfb983cbf2d20a87efe6b124fd7b4378b85a2803b2e88b66c62e94af7484f7cf0448a596c89c6c073b4395ed0e8ff6b4b6b84e296d4891dd9ff826461b3868
-EBUILD editorconfig-core-c-0.12.6.ebuild 1114 BLAKE2B 38bd336ea5a5073df926a69689127d73c17f96abbed0d1abeeabbd12a174eb52759ac701526be63a9dfc84d9e2c5764f1af743c46ab41a164cb01579b72929c5 SHA512 8ced6fb9263f476d3442dc6f77825113c66d68519e84b16b9dbd6c946d9d3854cb12c6afae94aa0af6f96a86c1e5a41536a759a55e69d7df3607eeee406c0990
+EBUILD editorconfig-core-c-0.12.6.ebuild 1163 BLAKE2B ec7baa7aec3e7ff00c811a8037fca610ca99951c74677638b34c8d9a64c493951a421138e4d70fe75625c4cf4cba498d09834ec6e10a71b7dbc5574cb2a564b9 SHA512 c721f2e09e74469530de8df7987614e4c7a82b6c878c539c3b6b56c373ef87ba4e83de28671de6ab387985e0107cf6ecdc7df71f11da96eabd804e65097f09bd
MISC metadata.xml 389 BLAKE2B 936516a5d13add9bcb0c94e20f3ea1eeb14119f2cae956c472848769907df123431f6dfa846bf82955a340a9c7f21bfe738203fe4a2bb6ea24ac22bf38d6e0e8 SHA512 5380c32b0d900044ce0d0562d6a71a0db840d01ebc48bdb34a5da2f61a8deff1a475fc03958796edb819d06f7e358a15c9fa4dcd20a91b64ca3c0e790746ad11
diff --git a/app-text/editorconfig-core-c/editorconfig-core-c-0.12.5.ebuild b/app-text/editorconfig-core-c/editorconfig-core-c-0.12.5.ebuild
deleted file mode 100644
index 37b393829999..000000000000
--- a/app-text/editorconfig-core-c/editorconfig-core-c-0.12.5.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="EditorConfig core library written in C"
-HOMEPAGE="https://github.com/editorconfig/editorconfig-core-c/"
-SRC_URI="https://github.com/editorconfig/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
-IUSE="cli doc"
-
-BDEPEND="doc? ( app-text/doxygen )"
-DEPEND="dev-libs/libpcre2:="
-RDEPEND="${DEPEND}
- cli? ( !dev-python/editorconfig[cli] )"
-
-src_prepare() {
- # Don't install the static library.
- sed -e '/install(TARGETS editorconfig_static/,+5d' -i src/lib/CMakeLists.txt || die
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_DOCUMENTATION=$(usex doc 'ON' 'OFF')
- -DBUILD_STATICALLY_LINKED_EXE=OFF
- )
- cmake_src_configure
-}
-
-src_install() {
- use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
- cmake_src_install
-
- if ! use cli; then
- rm -r "${ED}/usr/bin" || die
- fi
-}
diff --git a/app-text/editorconfig-core-c/editorconfig-core-c-0.12.6.ebuild b/app-text/editorconfig-core-c/editorconfig-core-c-0.12.6.ebuild
index 98699154c6f0..be53eaf511e3 100644
--- a/app-text/editorconfig-core-c/editorconfig-core-c-0.12.6.ebuild
+++ b/app-text/editorconfig-core-c/editorconfig-core-c-0.12.6.ebuild
@@ -18,7 +18,7 @@ BDEPEND="doc? ( app-text/doxygen )"
DEPEND="dev-libs/libpcre2:="
RDEPEND="
${DEPEND}
- cli? ( !dev-python/editorconfig[cli] )
+ cli? ( !dev-python/editorconfig[cli] !<dev-python/editorconfig-editorconfig-0.12.4-r1 )
"
# Header-only
DEPEND+=" dev-libs/uthash"