summaryrefslogtreecommitdiff
path: root/app-text
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/Manifest.gzbin48939 -> 48932 bytes
-rw-r--r--app-text/dblatex/Manifest1
-rw-r--r--app-text/dblatex/dblatex-0.3.12-r2.ebuild69
-rw-r--r--app-text/gocr/Manifest1
-rw-r--r--app-text/gocr/gocr-0.52-r1.ebuild53
5 files changed, 124 insertions, 0 deletions
diff --git a/app-text/Manifest.gz b/app-text/Manifest.gz
index ecd76da28c32..2996624afbd2 100644
--- a/app-text/Manifest.gz
+++ b/app-text/Manifest.gz
Binary files differ
diff --git a/app-text/dblatex/Manifest b/app-text/dblatex/Manifest
index 64cb71a14070..9fd10dbd726b 100644
--- a/app-text/dblatex/Manifest
+++ b/app-text/dblatex/Manifest
@@ -7,4 +7,5 @@ DIST dblatex-0.3.11py3.tar.bz2 1671505 BLAKE2B 44e89f5f8d81105a3401074ad765479c0
DIST dblatex3-0.3.12.tar.bz2 1693272 BLAKE2B 9310ce5db3b5f92e183f2656c5b1881edaf0208ae4f78f853332c844258fa38d443921fc42c03301773b1451ce272a538c305d765acbdc6eafbdcf25ebf5d2d3 SHA512 5bfa774c8dbe362775f6bbb5e1196e5a2bb1af239778133c12ddc725406ced67f3ff422433a2a1aa02d4431e9be58ba12e918379deb81fcd5b96533d2bdf029a
EBUILD dblatex-0.3.11-r1.ebuild 1827 BLAKE2B 34b52a951121ede45a6068422fcd3348b98fe3f5b764fa2eaa463a837c260a0dc881ffdfa7b2d63464062b1214e12f34a0ccf4c2b78942b81944b74ad86d1b9c SHA512 7c760c2e1caeb089c1b038535ee849becee4ce06fc9634a3c382b2f518ef81d60a9ab5869ca22f44efbc42dcb6be73d2d5237ea6940732bf09ce5fd793a0ca50
EBUILD dblatex-0.3.12-r1.ebuild 1977 BLAKE2B c63e95a6027a96e34b389abdbb5e51c51933e0d445e2786f97609e72c25b3827dff2eee311e53cf5075f7d15e967de4c9a35077f25de67b5675052bc334f06e4 SHA512 a0c0e50ad18bd39a234840fcd042f49a89184b850a0d33ba5304190f1f2a0900e5135a3f71ca6b26b3ed204e31279f0cd6d244af2ac1ddca4a350a90f900ea98
+EBUILD dblatex-0.3.12-r2.ebuild 1994 BLAKE2B 545978061d3ba41aa2ebbb5c0efa3865b9092cfa57adcc996dcfd9d8bbed399870fa55f6e71e5616d94dd16154434412cbd958b6765fd5b3da903053c9b5f1fd SHA512 0dae24c047bdce482a60edd3e53454452bfcb353129908d6ffdf71f30ddb4f1f5db143f6edad89576d6b39ea1e3eae94221034a2626ca79eb3b754f0920edb49
MISC metadata.xml 908 BLAKE2B e13f176739b3fb7a63a5eaeb704afa1c0b4e9740ea25dec54656c283cf9f8f614096aae407df8822414e054eaad0082c738c0a5a2acc91a51ce3f6b729fc37d6 SHA512 a39c4073b4cec1753724d16bcca023c9306eeac79bc7f008c6e090f85c4661733810c9864b91b9552fbbec242c01a312780ee780d11724ce26399bad3c9a0899
diff --git a/app-text/dblatex/dblatex-0.3.12-r2.ebuild b/app-text/dblatex/dblatex-0.3.12-r2.ebuild
new file mode 100644
index 000000000000..6902a9a37b05
--- /dev/null
+++ b/app-text/dblatex/dblatex-0.3.12-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+# Breaks installation of /usr/bin/dblatex, bug #906788
+#DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Transform DocBook using TeX macros"
+HOMEPAGE="http://dblatex.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/project/dblatex/dblatex/${P}/${PN}3-${PV}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="inkscape test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ dev-libs/kpathsea
+ dev-libs/libxslt
+ dev-libs/libxslt
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-latexrecommended
+ dev-texlive/texlive-mathscience
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-xetex
+ gnome-base/librsvg
+ media-gfx/imagemagick
+ >=media-gfx/fig2dev-3.2.9-r1
+ inkscape? ( media-gfx/inkscape )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}
+ test? ( ~${CATEGORY}/${P} )"
+
+S="${WORKDIR}/${PN}3-${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.11-path-logging.patch"
+ "${FILESDIR}/${PN}-0.3.11-setup.patch"
+ "${FILESDIR}/${PN}-0.3.11-encode.patch"
+)
+
+python_prepare_all() {
+ # Manual page is precomressed, but we will use our own compression later.
+ gunzip docs/manpage/dblatex.1.gz || die
+ # If we dont have inkscape we need to use an alternative SVG converter
+ use inkscape || eapply "${FILESDIR}/${PN}-0.3.11-no-inkscape-dependency.patch"
+ # If we use inscape however we want to make dblatex compatible with v1.0
+ use inkscape && eapply "${FILESDIR}/${PN}-0.3.11-inkscape-1.0.patch"
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # Move package documentation to a folder name containing version number
+ mv "${D}"/usr/share/doc/${PN} "${D}"/usr/share/doc/${PF} || die
+}
+
+python_test_all() {
+ emake -C tests/mathml
+}
diff --git a/app-text/gocr/Manifest b/app-text/gocr/Manifest
index b4fdf3b823eb..088dbaec2947 100644
--- a/app-text/gocr/Manifest
+++ b/app-text/gocr/Manifest
@@ -1,3 +1,4 @@
DIST gocr-0.52.tar.gz 445401 BLAKE2B 1f22f5377bb95053e3ab4ede074b3fceca4065f9ca0ede05a8023ebe807f41074f5ead84e133281e98be7f68f13b036dc759cccaf4a5688bf776f62f2de1970a SHA512 e2e6e690e7a32e32237c8b64b1a11719680c560592349df43f4b230f3c92bf324f98e473979b0913c42e33e8abbaf27952b6af173ea06eb5535878a9f608ce6d
+EBUILD gocr-0.52-r1.ebuild 1220 BLAKE2B f4ffe43a3592c105cf04ca302bd9a865d038fcfd5ca1848a01f6ded252c72c6672f1dd02c0d9336bb6d9d9d163d940a92f6133da4ee54ef18a4a631a0584e1e8 SHA512 695bdbdf77cf924550b1719da43505645030eefffcc635d7394042d40dda75d4f99f3aa870ab23fe12d8617d117723f777898f2b0e1fa32ee4ebd85aeedab988
EBUILD gocr-0.52.ebuild 1211 BLAKE2B 48d4d36a5f68ce119bb81f9c370bbe61f712a33fe94adf838b5bd37433dccf541888354e6e6b5c9097fc2c2e9e40aaa50cebafe38f403c3af93d7b37dd199968 SHA512 f2d02906a4c3382c602bc020d6365f2ea0ef19370efc7005764afba01714c52122305620cb4e11eb2077a62a2a84fa030325ab62c62d84f374a8e22513f5d984
MISC metadata.xml 242 BLAKE2B 6d6452effca096b9ddfe9cf937bae671b0395d8757aa1c6e56be35d80495d6d6ad96c992c297191853da2e915094175cfc63d7ff74eab76885d5641ecb2c6632 SHA512 e0ecf1bfae6c474b11ceb51240d5cce9978c17adc03c606327ae7086bfc55ef20da3934c25ab4ecef4dfd4db63f73f5ccb44670c5e860357eb4da1af2eb2d02f
diff --git a/app-text/gocr/gocr-0.52-r1.ebuild b/app-text/gocr/gocr-0.52-r1.ebuild
new file mode 100644
index 000000000000..c598b8bc26bd
--- /dev/null
+++ b/app-text/gocr/gocr-0.52-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="An OCR (Optical Character Recognition) reader"
+HOMEPAGE="https://www-e.uni-magdeburg.de/jschulen/ocr/"
+SRC_URI="http://www-e.uni-magdeburg.de/jschulen/ocr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc scanner tk"
+
+DEPEND="
+ >=media-libs/netpbm-9.12
+ doc? (
+ >=media-gfx/fig2dev-3.2.9-r1
+ app-text/ghostscript-gpl
+ )
+ tk? ( dev-lang/tk )"
+RDEPEND="${DEPEND}
+ tk? (
+ media-gfx/xli
+ scanner? ( media-gfx/xsane )
+ )"
+
+src_compile() {
+ local targets=( src man )
+ use doc && targets+=( doc examples )
+
+ emake "${targets[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" exec_prefix="${EPREFIX}/usr" install
+ einstalldocs
+ dodoc HISTORY REMARK.txt REVIEW
+
+ # remove the tk frontend if tk is not selected
+ if ! use tk; then
+ rm "${ED}"/usr/bin/gocr.tcl || die
+ fi
+
+ # and install the documentation and examples
+ if use doc; then
+ dodoc doc/gocr.html doc/examples.txt doc/unicode.txt
+
+ docinto examples
+ dodoc examples/*.{fig,tex,pcx}
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}