summaryrefslogtreecommitdiff
path: root/app-text/zeal/zeal-0.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/zeal/zeal-0.7.1.ebuild')
-rw-r--r--app-text/zeal/zeal-0.7.1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-text/zeal/zeal-0.7.1.ebuild b/app-text/zeal/zeal-0.7.1.ebuild
new file mode 100644
index 000000000000..517aa25b87d1
--- /dev/null
+++ b/app-text/zeal/zeal-0.7.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake edos2unix xdg-utils
+
+DESCRIPTION="Offline documentation browser inspired by Dash"
+HOMEPAGE="https://zealdocs.org/"
+SRC_URI="https://github.com/zealdocs/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ app-arch/libarchive:=
+ dev-db/sqlite:3
+ dev-qt/qtbase:6[concurrent,gui,network,widgets]
+ dev-qt/qtwebchannel:6
+ dev-qt/qtwebengine:6[widgets]
+ x11-libs/libX11
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-keysyms
+"
+RDEPEND="${DEPEND}
+ x11-themes/hicolor-icon-theme
+"
+BDEPEND="kde-frameworks/extra-cmake-modules"
+
+PATCHES=(
+ "${FILESDIR}/disable-werror.patch"
+ "${FILESDIR}/qt6.patch"
+ "${FILESDIR}/add-missing-qt-components.patch"
+)
+
+src_prepare() {
+ edos2unix "${S}/assets/freedesktop/org.zealdocs.zeal.desktop"
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DZEAL_RELEASE_BUILD=ON
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}