summaryrefslogtreecommitdiff
path: root/app-text/xournalpp/xournalpp-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xournalpp/xournalpp-9999.ebuild')
-rw-r--r--app-text/xournalpp/xournalpp-9999.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/app-text/xournalpp/xournalpp-9999.ebuild b/app-text/xournalpp/xournalpp-9999.ebuild
index a1105db47c04..3e95f5804d98 100644
--- a/app-text/xournalpp/xournalpp-9999.ebuild
+++ b/app-text/xournalpp/xournalpp-9999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-# Upstream only support 5.3 (see CMakeLists.txt), also bug #854615
-LUA_COMPAT=( lua5-3 )
+LUA_COMPAT=( lua5-3 lua5-4 )
inherit cmake lua-single xdg
if [[ ${PV} == *9999 ]]; then
@@ -46,4 +45,14 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-1.1.1-nostrip.patch"
"${FILESDIR}/${PN}-1.1.1-nocompress.patch"
+ "${FILESDIR}/${PN}-1.1.3-lua-5-4.patch"
+ "${FILESDIR}/${PN}-1.1.3-gcc13.patch"
)
+
+src_configure() {
+ local mycmakeargs=(
+ -DLUA_VERSION="$(lua_get_version)"
+ )
+
+ cmake_src_configure
+}