summaryrefslogtreecommitdiff
path: root/app-text/xmlto
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xmlto')
-rw-r--r--app-text/xmlto/Manifest1
-rw-r--r--app-text/xmlto/xmlto-0.0.28-r4.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-text/xmlto/Manifest b/app-text/xmlto/Manifest
index bd23380ba4af..302a6be7ba95 100644
--- a/app-text/xmlto/Manifest
+++ b/app-text/xmlto/Manifest
@@ -1,4 +1,5 @@
AUX xmlto-0.0.22-format_fo_passivetex_check.patch 2286 BLAKE2B eb004b4fa394840b8e6fd792bfacfee75d180a1493d960348a33c7737a33a15a809fff28f4b6ade3deb045b629eb48a675b56037da56a7fabcd20718dfdaa6a4 SHA512 c8eeb3dc909431dd2fb9f5286b6ee98a40dce80a29606a9884bdab50c039ac90097720b9b968dfac76546492844de0b72f2f6c937da14b47142ad81b897023f4
DIST xmlto-0.0.28.tar.bz2 127921 BLAKE2B 12ef3e2e1436c330e7b003d08f4a4d4032d70255777956949eb8b47b6f5466e7c158b0f85dc87069c1e379603cac0b01c88589f98ca1ef9e862f0aef31169f6d SHA512 6e0c4968d4f1b7a3b132904182aa72a73f6167553eabdeb65cfafa6295ef7b960541685769d04144207963cca77b0c44db4f9fbb2796348ffcb37b3b399f18f1
EBUILD xmlto-0.0.28-r3.ebuild 1420 BLAKE2B fb16508bb472a89a2312c7fba3d61694f59fbbf28f6a011fcb000439146ac40f7175a85fe416958bb0cc491d8388b02ddfa9782a3ee90f898f1c56b57dc37b51 SHA512 5d40affae036b2dc9e1d44136c00b3cd68327a06d7946cebb219c597acadabd0b64f006481e439693e28ba28373c44c7c89e5f5ef9ce758274791edc82642ad5
+EBUILD xmlto-0.0.28-r4.ebuild 1360 BLAKE2B 7341ea47241f06db2bb73113a3f5fde6d5cb1456d773d6121ddbf7bcceaff5b66b85f4d5553af208b7681706d2ec5d1add76e1d34590abc23d5850f647c980df SHA512 2a8348c52a358101705f928b2d98b1924a8665cc01b4b9562b66e739ed09dd9e6952ea5a241aa5b24373612ce2d6b142ecb39530fd7750c5e074736dc205045a
MISC metadata.xml 247 BLAKE2B 17c173af66eaa7e25c4a88ae4e5b8cba24cd1f324224ddeb95774690a862c678f2c6c51cfd175aaa3781efa83d0526c01883b7888cba6fb9ba8f62b9bef5942f SHA512 f2b92e9bda8e4466d98436c15ee46b2a382afa4bfcf868678bb245abda936298ed41d03f3dcf5a61000ae1b1031a5578635e15293d63c531773d6a42d356af47
diff --git a/app-text/xmlto/xmlto-0.0.28-r4.ebuild b/app-text/xmlto/xmlto-0.0.28-r4.ebuild
new file mode 100644
index 000000000000..0bbb710eeaec
--- /dev/null
+++ b/app-text/xmlto/xmlto-0.0.28-r4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Script for converting XML and DocBook documents to a variety of output formats"
+HOMEPAGE="https://pagure.io/xmlto"
+SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="latex text"
+
+RDEPEND="app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ || ( sys-apps/util-linux app-misc/getopt )
+ text? ( || ( virtual/w3m www-client/elinks www-client/links www-client/lynx ) )
+ latex? ( dev-texlive/texlive-formatsextra )"
+# We only depend on flex when we patch the input lexer.
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog FAQ NEWS README THANKS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.0.22-format_fo_passivetex_check.patch
+)
+
+src_prepare() {
+ default
+
+ # fix symbol clash on Solaris
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i -e 's/\(attrib\|val\)/XMLTO\1/g' xmlif/xmlif.l || die
+ fi
+}
+
+src_configure() {
+ # We don't want the script to detect /bin/sh if it is bash.
+ export ac_cv_path_BASH="${BASH}"
+ has_version sys-apps/util-linux || export GETOPT=getopt-long
+
+ econf
+}