summaryrefslogtreecommitdiff
path: root/app-text/xml2rfc/xml2rfc-3.18.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xml2rfc/xml2rfc-3.18.0.ebuild')
-rw-r--r--app-text/xml2rfc/xml2rfc-3.18.0.ebuild33
1 files changed, 19 insertions, 14 deletions
diff --git a/app-text/xml2rfc/xml2rfc-3.18.0.ebuild b/app-text/xml2rfc/xml2rfc-3.18.0.ebuild
index de4584d36aff..330299f1066c 100644
--- a/app-text/xml2rfc/xml2rfc-3.18.0.ebuild
+++ b/app-text/xml2rfc/xml2rfc-3.18.0.ebuild
@@ -4,29 +4,25 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
DESCRIPTION="Generates RFCs and IETF drafts from document source in XML"
-HOMEPAGE="https://ietf-tools.github.io/xml2rfc/ https://github.com/ietf-tools/xml2rfc"
-SRC_URI="https://github.com/ietf-tools/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://ietf-tools.github.io/xml2rfc/
+ https://github.com/ietf-tools/xml2rfc/
+ https://pypi.org/project/xml2rfc/
+"
+SRC_URI="
+ https://github.com/ietf-tools/xml2rfc/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
-RESTRICT="!test? ( test )"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64"
-BDEPEND="
- test? (
- >=dev-python/pypdf-3.2.1[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/dict2xml[${PYTHON_USEDEP}]
- dev-python/weasyprint[${PYTHON_USEDEP}]
- media-fonts/noto[cjk]
- )
-"
-
RDEPEND="
>=dev-python/platformdirs-3.6.0[${PYTHON_USEDEP}]
dev-python/ConfigArgParse[${PYTHON_USEDEP}]
@@ -41,6 +37,15 @@ RDEPEND="
dev-python/requests[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
+BDEPEND="
+ test? (
+ >=dev-python/pypdf-3.2.1[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/dict2xml[${PYTHON_USEDEP}]
+ dev-python/weasyprint[${PYTHON_USEDEP}]
+ media-fonts/noto[cjk]
+ )
+"
distutils_enable_tests unittest