summaryrefslogtreecommitdiff
path: root/app-text/xml2rfc/xml2rfc-3.17.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xml2rfc/xml2rfc-3.17.1.ebuild')
-rw-r--r--app-text/xml2rfc/xml2rfc-3.17.1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/app-text/xml2rfc/xml2rfc-3.17.1.ebuild b/app-text/xml2rfc/xml2rfc-3.17.1.ebuild
deleted file mode 100644
index c6054229ef12..000000000000
--- a/app-text/xml2rfc/xml2rfc-3.17.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Generates RFCs and IETF drafts from document source in XML"
-HOMEPAGE="https://ietf-tools.github.io/xml2rfc/ https://github.com/ietf-tools/xml2rfc"
-SRC_URI="https://github.com/ietf-tools/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-RESTRICT="!test? ( test )"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64"
-
-BDEPEND="
- test? (
- >=dev-python/pypdf-3.2.1[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/dict2xml[${PYTHON_USEDEP}]
- dev-python/weasyprint[${PYTHON_USEDEP}]
- media-fonts/noto[cjk]
- )
-"
-
-RDEPEND="
- dev-python/appdirs[${PYTHON_USEDEP}]
- dev-python/ConfigArgParse[${PYTHON_USEDEP}]
- dev-python/intervaltree[${PYTHON_USEDEP}]
- dev-python/google-i18n-address[${PYTHON_USEDEP}]
- >=dev-python/html5lib-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.1.2[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
- dev-python/pycountry[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- default
- # Disable broken PdfWriterTests.
- sed -i 's/ PdfWriterTests(unittest.TestCase):/ PdfWriterTests:/' test.py || die
-}