summaryrefslogtreecommitdiff
path: root/app-text/xlsx2csv/xlsx2csv-0.7.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xlsx2csv/xlsx2csv-0.7.3.ebuild')
-rw-r--r--app-text/xlsx2csv/xlsx2csv-0.7.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-text/xlsx2csv/xlsx2csv-0.7.3.ebuild b/app-text/xlsx2csv/xlsx2csv-0.7.3.ebuild
new file mode 100644
index 000000000000..213c2d7ff6be
--- /dev/null
+++ b/app-text/xlsx2csv/xlsx2csv-0.7.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Convert MS Office xlsx files to CSV"
+HOMEPAGE="https://github.com/dilshod/xlsx2csv/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-lang/perl"
+
+python_compile_all() {
+ emake -C man
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/${PN}.1
+}