summaryrefslogtreecommitdiff
path: root/app-text/xindy/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xindy/files')
-rw-r--r--app-text/xindy/files/xindy-2.4-configure.patch21
-rw-r--r--app-text/xindy/files/xindy-2.4-locale.patch22
-rw-r--r--app-text/xindy/files/xindy-2.4-nogrep.patch13
-rw-r--r--app-text/xindy/files/xindy-2.4-perl5.26.patch11
4 files changed, 67 insertions, 0 deletions
diff --git a/app-text/xindy/files/xindy-2.4-configure.patch b/app-text/xindy/files/xindy-2.4-configure.patch
new file mode 100644
index 000000000000..b76341f1f759
--- /dev/null
+++ b/app-text/xindy/files/xindy-2.4-configure.patch
@@ -0,0 +1,21 @@
+--- xindy-2.4/configure.ac.orig 2010-05-10 16:12:10.000000000 -0700
++++ xindy-2.4/configure.ac 2010-09-28 23:43:39.591495118 -0700
+@@ -42,12 +42,16 @@
+
+ # Test for building make-rules
+ AC_ARG_ENABLE(make-rules, AS_HELP_STRING([--enable-make-rules ],[build and install make-rules package (default is YES)]),[BUILDRULES=$enableval],[BUILDRULES=yes])
+-test "$BUILDRULES" = "yes" && AC_PROG_LATEX
++if test "x$BUILDRULES" = "xyes"; then
++ AC_PROG_LATEX
++fi
+ AM_CONDITIONAL(BUILDRULES, test "$BUILDRULES" = "yes")
+
+ # Test for building Documentation
+ AC_ARG_ENABLE(docs, AS_HELP_STRING([--enable-docs ],[build and install documentation (default is YES)]),[BUILDDOCS=$enableval],[BUILDDOCS=yes])
+-test "$BUILDDOCS" = "yes" && AC_PROG_PDFLATEX
++if test "x$BUILDDOCS" = "xyes"; then
++ AC_PROG_PDFLATEX
++fi
+ AM_CONDITIONAL(BUILDDOCS, test "$BUILDDOCS" = "yes")
+
+ # Checks for programs:
diff --git a/app-text/xindy/files/xindy-2.4-locale.patch b/app-text/xindy/files/xindy-2.4-locale.patch
new file mode 100644
index 000000000000..c2edccc4bef6
--- /dev/null
+++ b/app-text/xindy/files/xindy-2.4-locale.patch
@@ -0,0 +1,22 @@
+--- xindy-2.4.orig/src/Makefile.am
++++ xindy-2.4/src/Makefile.am
+@@ -41,7 +41,7 @@
+ DEFAULTS = defaults.xdy
+ DUMP_XINDY = dump-xindy.lsp
+ MEMFILE = xindy.mem
+-CLISP = @CLISP@ -q -E iso-8859-1
++CLISP = @CLISP@ -q
+
+ xindy.mem: $(DEFAULTS) $(FAS) $(DUMP_XINDY)
+ rm -f $(MEMFILE)
+--- xindy-2.4.orig/user-commands/xindy.in
++++ xindy-2.4/user-commands/xindy.in
+@@ -777,7 +777,7 @@
+ sub call_xindy ( $$ ) {
+ my ($mem_file, $xindy_exp) = @_;
+
+- my @command = ($clisp, '-M', $mem_file, '-E', 'iso-8859-1');
++ my @command = ($clisp, '-M', $mem_file);
+ if ( $interactive ) {
+ print "Proposed xindy expression:\n\n$xindy_exp\n" unless $quiet;
+ } else {
diff --git a/app-text/xindy/files/xindy-2.4-nogrep.patch b/app-text/xindy/files/xindy-2.4-nogrep.patch
new file mode 100644
index 000000000000..41f1b3a03609
--- /dev/null
+++ b/app-text/xindy/files/xindy-2.4-nogrep.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/573794
+
+--- xindy-2.4-orig/make-rules/inputenc/Makefile.am
++++ xindy-2.4/make-rules/inputenc/Makefile.am
+@@ -43,7 +43,7 @@
+ latin.xdy : latin1.xdy latin2.xdy latin3.xdy
+ echo ';; Generated from latin?.xdy' >latin.xdy
+ echo >>latin.xdy
+- sort -u latin?.xdy | grep -v '^;' >>latin.xdy
++ sort -u latin?.xdy | sed '/^;/d' >>latin.xdy
+
+ %.xdy %.idx :
+ $(PERL) $(srcdir)/make-testidx.pl TS1,T2A,T1 $* >$*.tex
diff --git a/app-text/xindy/files/xindy-2.4-perl5.26.patch b/app-text/xindy/files/xindy-2.4-perl5.26.patch
new file mode 100644
index 000000000000..657b5e94c362
--- /dev/null
+++ b/app-text/xindy/files/xindy-2.4-perl5.26.patch
@@ -0,0 +1,11 @@
+--- xindy-2.4/make-rules/inputenc/make-inp-rules.pl
++++ xindy-2.4/make-rules/inputenc/make-inp-rules.pl
+@@ -8,7 +8,7 @@
+
+
+ while (<STDIN>) {
+- if (/\\indexentry{(.+)--([8-9a-f][0-9a-f])\}\{1\}/) {
++ if (/\\indexentry\{(.+)--([8-9a-f][0-9a-f])\}\{1\}/) {
+ if (!($1 =~ /inputenc Error/)) {
+ $i = hex($2);
+ $macro = $1;