summaryrefslogtreecommitdiff
path: root/app-text/xapers/xapers-0.9.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xapers/xapers-0.9.3.ebuild')
-rw-r--r--app-text/xapers/xapers-0.9.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/xapers/xapers-0.9.3.ebuild b/app-text/xapers/xapers-0.9.3.ebuild
new file mode 100644
index 000000000000..8aa138381611
--- /dev/null
+++ b/app-text/xapers/xapers-0.9.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2016-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Personal document indexing system"
+HOMEPAGE="https://gitlab.com/wpettersson/xapers/"
+SRC_URI="https://gitlab.com/wpettersson/${PN}/-/archive/${PV}/${P}.tar.bz2"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="app-text/poppler[utils]
+ dev-libs/xapian-bindings[python,${PYTHON_USEDEP}]
+ dev-python/pybtex[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ x11-misc/xclip
+ x11-misc/xdg-utils"
+
+BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ cd test || die
+ ./all || die
+}