summaryrefslogtreecommitdiff
path: root/app-text/xapers/xapers-0.8.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xapers/xapers-0.8.2.ebuild')
-rw-r--r--app-text/xapers/xapers-0.8.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-text/xapers/xapers-0.8.2.ebuild b/app-text/xapers/xapers-0.8.2.ebuild
new file mode 100644
index 000000000000..d835d91dec96
--- /dev/null
+++ b/app-text/xapers/xapers-0.8.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2016-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Personal document indexing system"
+HOMEPAGE="https://finestructure.net/xapers/"
+SRC_URI="https://finestructure.net/xapers/releases/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="app-text/poppler[utils]
+ dev-libs/xapian-bindings[python,${PYTHON_USEDEP}]
+ dev-python/bibtexparser[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ x11-misc/xclip
+ x11-misc/xdg-utils"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"