summaryrefslogtreecommitdiff
path: root/app-text/wv
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/wv')
-rw-r--r--app-text/wv/Manifest3
-rw-r--r--app-text/wv/files/wv-1.2.9-C99-decls.patch101
-rw-r--r--app-text/wv/wv-1.2.9-r3.ebuild5
3 files changed, 107 insertions, 2 deletions
diff --git a/app-text/wv/Manifest b/app-text/wv/Manifest
index e8cd2f74176c..bcde33e1fd70 100644
--- a/app-text/wv/Manifest
+++ b/app-text/wv/Manifest
@@ -1,4 +1,5 @@
+AUX wv-1.2.9-C99-decls.patch 2193 BLAKE2B 9b8e0008c989c2f65d59678fa33d4c4630537376ebf4d75e7aafa9f4c48a4cbd774cd9c33800e97bdffa38fbeefbd8846778d3035c37a96d4de2c9b50ec88457 SHA512 333a4aad45d29128ffd38509a6d62ac3ab8869b5507e34d3507a62161b3cf79046e3e844b506c55e8bcba1ca35993b3303818a997b66b67c0ba162bc659ecbe0
AUX wv-1.2.9-format-security.patch 336 BLAKE2B 18641a15c75a32250012771bd8ca8b0739f503ef8d1d2eebe23f2d378996aa3f6e2f0cfa72f8077add3db33f8ece86c57e80cc5b868719472b45ba1bed10a7d0 SHA512 99fef3bec0f129ae2d138c50d1e3e9288d5309db87a72d9b1970d1d230e20be3469b423f0b74c5083a0a5cdca8fed0b2ca32ec1fefdca22f213e4a02a6bbd405
DIST wv-1.2.9.tar.gz 616256 BLAKE2B 6a6aa6b5f87a934c703c8a74d85af3d7aa84dcd2bc613a3af7fb8d69a9339e71ba2618ae8f725b90c3fe0b0199f4b224bdb32a50c2b6b6614f84b6a14437633f SHA512 ae5c762012595ce8922bfda8749ad3e9cb055edab30152c3a5feaaf3ca6601f357d1e301b179e9a5860cd99452dd6e63e5f44f5bcc12f8db148bdd334e0200a5
-EBUILD wv-1.2.9-r3.ebuild 1423 BLAKE2B 4721ea639ca63859a8ea688361261394321ef1a40b08c1dafcf9d88e42de77b1e740b282b6fd033bfe6d75efa28297dbf9f1a836ca755f662531bae16ff163c7 SHA512 9404ff447c62364ff7b94900983393a53e1f4b05e3c3f060fd67bdf9b5b9a70cc430ddefec8303958a4d20bf2fd784fd8dd66e6a4a28befd92bd33c56e401810
+EBUILD wv-1.2.9-r3.ebuild 1460 BLAKE2B 2220e363afb5b502acb968752122e7d64cad27c6aa6470def36ffc43b86384da4cc3e30d2f628f1b62de707d192682b9b72a476d5b39f4f616f9cf17016f4840 SHA512 0ab75bb63d699e3b63ca2f2a49ef8a1d16446d3261be8fd82dafd01a8a3fd02deb99c4fb1063ad768b9bf2f09c67b66c6bf2d7257aeaa768340cbb51a26c83df
MISC metadata.xml 449 BLAKE2B ac74f5a8ee805072c669569b336f99840bd4a868aaedca72764c516040444b3c216bb33d9369d020d46394add0de746597c33c43c6466be4e672c2c017eec390 SHA512 bb4871f0e9a9801aeac5660b82c480d42a62d0d06641a085887d7359aace546b10071d09e92f730d1958aaee9444752723aa5d05fe9417842413b92270bdd174
diff --git a/app-text/wv/files/wv-1.2.9-C99-decls.patch b/app-text/wv/files/wv-1.2.9-C99-decls.patch
new file mode 100644
index 000000000000..b200055cf5b8
--- /dev/null
+++ b/app-text/wv/files/wv-1.2.9-C99-decls.patch
@@ -0,0 +1,101 @@
+--- a/field.c
++++ b/field.c
+@@ -25,6 +25,7 @@
+ #include <stdlib.h>
+ #include <ctype.h>
+ #include <string.h>
++#include <strings.h>
+ #include <time.h>
+
+ #include "wv.h"
+--- a/md5.c
++++ b/md5.c
+@@ -57,7 +57,7 @@
+ #include "md5.h"
+
+ /* forward declaration */
+-static void Transform ();
++static void Transform (UINT4 *buf, UINT4 *in);
+
+ static unsigned char PADDING[64] = {
+ 0x80, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
+@@ -103,8 +103,7 @@
+ }
+
+ void
+-wvMD5Init (mdContext)
+- wvMD5_CTX *mdContext;
++wvMD5Init (wvMD5_CTX *mdContext)
+ {
+ mdContext->i[0] = mdContext->i[1] = (UINT4) 0;
+
+@@ -117,10 +116,7 @@
+ }
+
+ void
+-wvMD5Update (mdContext, inBuf, inLen)
+- wvMD5_CTX *mdContext;
+- unsigned char *inBuf;
+- unsigned int inLen;
++wvMD5Update (wvMD5_CTX *mdContext, unsigned char *inBuf, unsigned int inLen)
+ {
+ UINT4 in[16];
+ int mdi;
+@@ -155,8 +151,7 @@
+ }
+
+ void
+-wvMD5Final (mdContext)
+- wvMD5_CTX *mdContext;
++wvMD5Final (wvMD5_CTX *mdContext)
+ {
+ UINT4 in[16];
+ int mdi;
+@@ -198,9 +193,7 @@
+ /* Basic MD5 step. Transform buf based on in.
+ */
+ static void
+-Transform (buf, in)
+- UINT4 *buf;
+- UINT4 *in;
++Transform (UINT4 *buf, UINT4 *in)
+ {
+ UINT4 a = buf[0], b = buf[1], c = buf[2], d = buf[3];
+
+--- a/md5.h
++++ b/md5.h
+@@ -48,9 +48,9 @@
+ unsigned char digest[16]; /* actual digest after MD5Final call */
+ } wvMD5_CTX;
+
+-void wvMD5Init ();
+-void wvMD5Update ();
+-void wvMD5Final ();
++void wvMD5Init (wvMD5_CTX *mdContext);
++void wvMD5Update (wvMD5_CTX *mdContext, unsigned char *inBuf, unsigned int inLen);
++void wvMD5Final (wvMD5_CTX *mdContext);
+
+ /*
+ **********************************************************************
+--- a/wvConfig.c
++++ b/wvConfig.c
+@@ -24,6 +24,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
++#include <strings.h>
+ #include <math.h>
+ #include <ctype.h>
+ #include "wv.h"
+--- a/wvparse.c
++++ b/wvparse.c
+@@ -35,6 +35,9 @@
+ #include <gsf/gsf-input-stdio.h>
+ #include <gsf/gsf-utils.h>
+
++int wvOLEDecode_gsf (wvParseStruct * ps, GsfInput *path, wvStream ** mainfd, wvStream ** tablefd0,
++ wvStream ** tablefd1, wvStream ** data, wvStream ** summary);
++
+ int
+ wvInit (void)
+ {
diff --git a/app-text/wv/wv-1.2.9-r3.ebuild b/app-text/wv/wv-1.2.9-r3.ebuild
index 4876a095e7fd..cf99d1c2a144 100644
--- a/app-text/wv/wv-1.2.9-r3.ebuild
+++ b/app-text/wv/wv-1.2.9-r3.ebuild
@@ -28,7 +28,10 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
-PATCHES=( "${FILESDIR}"/${P}-format-security.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-format-security.patch
+ "${FILESDIR}"/${P}-C99-decls.patch
+)
src_prepare() {
default