summaryrefslogtreecommitdiff
path: root/app-text/winefish/winefish-1.3.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/winefish/winefish-1.3.3-r2.ebuild')
-rw-r--r--app-text/winefish/winefish-1.3.3-r2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-text/winefish/winefish-1.3.3-r2.ebuild b/app-text/winefish/winefish-1.3.3-r2.ebuild
new file mode 100644
index 000000000000..2c873d65af7f
--- /dev/null
+++ b/app-text/winefish/winefish-1.3.3-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils xdg-utils
+
+MY_PV=${PV/%[[:alpha:]]/}
+
+DESCRIPTION="LaTeX editor based on Bluefish"
+HOMEPAGE="https://github.com/viettug/winefish"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="spell"
+
+RDEPEND="
+ >=dev-libs/libpcre-6.3
+ >=x11-libs/gtk+-2.4:2
+ spell? ( app-text/aspell )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-desktop.patch
+ "${FILESDIR}"/${P}-doc.patch
+ "${FILESDIR}"/${P}-memset.patch
+ "${FILESDIR}"/${P}-nostrip.patch
+ "${FILESDIR}"/${P}-version.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-update-databases
+}
+
+src_install() {
+ emake install DESTDIR="${D}" docdir=/usr/share/doc/${PF}/html
+ dodoc AUTHORS CHANGES README ROADMAP THANKS TODO
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}