summaryrefslogtreecommitdiff
path: root/app-text/unrtf/unrtf-0.21.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/unrtf/unrtf-0.21.9.ebuild')
-rw-r--r--app-text/unrtf/unrtf-0.21.9.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-text/unrtf/unrtf-0.21.9.ebuild b/app-text/unrtf/unrtf-0.21.9.ebuild
new file mode 100644
index 000000000000..39b505eb8e6d
--- /dev/null
+++ b/app-text/unrtf/unrtf-0.21.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Converts RTF files to various formats"
+HOMEPAGE="https://www.gnu.org/software/unrtf/unrtf.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
+IUSE=""
+
+src_prepare() {
+ # eautoreconf fails when automake-1.14* is installed. Please check with
+ # next version bump if we still need this workaround.
+ rm aclocal.m4 || die
+
+ epatch "${FILESDIR}"/unrtf-0.21.8-automake-fix.patch
+ epatch "${FILESDIR}"/${PN}-0.21.8-iconv-detection.patch
+ eautoreconf
+}