summaryrefslogtreecommitdiff
path: root/app-text/ttf2pk2/ttf2pk2-2.0_p20170524-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/ttf2pk2/ttf2pk2-2.0_p20170524-r1.ebuild')
-rw-r--r--app-text/ttf2pk2/ttf2pk2-2.0_p20170524-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-text/ttf2pk2/ttf2pk2-2.0_p20170524-r1.ebuild b/app-text/ttf2pk2/ttf2pk2-2.0_p20170524-r1.ebuild
new file mode 100644
index 000000000000..5a5ec2a0e649
--- /dev/null
+++ b/app-text/ttf2pk2/ttf2pk2-2.0_p20170524-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Freetype 2 based TrueType font to TeX's PK format converter"
+HOMEPAGE="http://tug.org/texlive/"
+SRC_URI="mirror://gentoo/texlive-${PV#*_p}-source.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Note about blockers: it is a freetype2 based replacement for ttf2pk and
+# ttf2tfm from freetype1, so block freetype1.
+# It installs some data that collides with
+# dev-texlive/texlive-langcjk-2011[source]. Hope it'd be fixed with 2012,
+# meanwhile we can start dropping freetype1.
+RDEPEND=">=dev-libs/kpathsea-6.2.1
+ media-libs/freetype:2
+ sys-libs/zlib
+ !media-libs/freetype:1
+ !=dev-texlive/texlive-langcjk-2011*[source]"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+S=${WORKDIR}/texlive-${PV#*_p}-source/texk/${PN}
+
+src_prepare () {
+ # Bug 654770
+ cd "${WORKDIR}/texlive-${PV#*_p}-source"
+ eapply "${FILESDIR}"/ttf2pk2-2.0_p20170524-freetype2-config.patch
+ cd "${S}"
+ eautoreconf
+ eapply_user
+}
+
+src_configure() {
+ econf --with-system-kpathsea \
+ --with-system-freetype2 \
+ --with-system-zlib
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc BUGS README TODO ChangeLog
+}