summaryrefslogtreecommitdiff
path: root/app-text/scrollkeeper-dtd
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/scrollkeeper-dtd')
-rw-r--r--app-text/scrollkeeper-dtd/Manifest1
-rw-r--r--app-text/scrollkeeper-dtd/scrollkeeper-dtd-1.0-r2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-text/scrollkeeper-dtd/Manifest b/app-text/scrollkeeper-dtd/Manifest
index 00b37a975cac..bc9d49ad1c0e 100644
--- a/app-text/scrollkeeper-dtd/Manifest
+++ b/app-text/scrollkeeper-dtd/Manifest
@@ -1,3 +1,4 @@
DIST scrollkeeper-omf.dtd 11031 BLAKE2B 47a52f587447f30c1c93ebdb4d1339d714260c7bcf16711591edb0b0f8a41d6694a1f64f0306d0c296c032869176b884adb50762eaa445f50684820effcb9399 SHA512 edb38d85352d0ed4a4fd1eea108cd88696d2f0759bc4402d4b7f85aa56b5647ca5a518de14deb3a429344ede474d42a64b90100e5d3c772ae6e5e47a47d86ff0
EBUILD scrollkeeper-dtd-1.0-r1.ebuild 1505 BLAKE2B c1367d7fd3763cb070ca47bbeb3c98c122085bb5ef91c41bc473c6199949d29578f67eb812f2d92d397c2bd81f941575be64cbbe546a366ffe942c261acc688c SHA512 db79a9b75b1305905f077f15146565abfd7e4bdecbeeccee7731213ab5f528d8ff94cee3e921fbbaff15ff271fc4b7b60696973f418760ece6fe8a1be5fecab5
+EBUILD scrollkeeper-dtd-1.0-r2.ebuild 1481 BLAKE2B 2b2b1245ce96f1acd7df24577bf6ab982313b971be1e2c2f37c026cf0035d9cc37d75251c321626b283727c82fa7ff7603355b63dcecd7bb88e38eb5fd8853af SHA512 145a92e4d962f0d90f8fa8b39cfb264c234bd918fecf3da9961b9a824f29d1d51c28f29311677071daf530ab91c14a6edb51f20a41d0bf69eca5db732044a214
MISC metadata.xml 360 BLAKE2B e02a3a926e53a4229f5ab5df676053e33cfe53b6ba76db93000fb7fd80aec82bd876bd6f674f0ba5528f0893b440411010c44cac275cb11e0573b9bb529aa95f SHA512 2fff97b30cf20a54d073b4bd82e61b91691c157622c1450fb3b49c78051f107886c9e628ff6fd6f8789621076e8859e70d231eb26d6a182291f8cf330f183e5c
diff --git a/app-text/scrollkeeper-dtd/scrollkeeper-dtd-1.0-r2.ebuild b/app-text/scrollkeeper-dtd/scrollkeeper-dtd-1.0-r2.ebuild
new file mode 100644
index 000000000000..3e3ec497a77e
--- /dev/null
+++ b/app-text/scrollkeeper-dtd/scrollkeeper-dtd-1.0-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DTD_FILE="scrollkeeper-omf.dtd"
+
+DESCRIPTION="DTD from the Scrollkeeper package"
+HOMEPAGE="https://scrollkeeper.sourceforge.net/"
+SRC_URI="https://scrollkeeper.sourceforge.net/dtds/scrollkeeper-omf-1.0/${DTD_FILE}"
+S="${WORKDIR}"
+
+LICENSE="FDL-1.1"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
+
+RDEPEND=">=dev-libs/libxml2-2.4.19"
+DEPEND="${RDEPEND}"
+
+src_unpack() { :; }
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/xml/scrollkeeper/dtds
+ doins "${DISTDIR}/${DTD_FILE}"
+}
+
+pkg_postinst() {
+ einfo "Installing catalog..."
+
+ # Install regular DOCTYPE catalog entry
+ "${EROOT}"/usr/bin/xmlcatalog --noout --add "public" \
+ "-//OMF//DTD Scrollkeeper OMF Variant V1.0//EN" \
+ "${EROOT}"/usr/share/xml/scrollkeeper/dtds/${DTD_FILE} \
+ "${EROOT}"/etc/xml/catalog
+
+ # Install catalog entry for calls like: xmllint --dtdvalid URL ...
+ "${EROOT}"/usr/bin/xmlcatalog --noout --add "system" \
+ "${SRC_URI}" \
+ "${EROOT}"/usr/share/xml/scrollkeeper/dtds/${DTD_FILE} \
+ "${EROOT}"/etc/xml/catalog
+}
+
+pkg_postrm() {
+ # Remove all sk-dtd from the cache
+ einfo "Cleaning catalog..."
+
+ "${EROOT}"/usr/bin/xmlcatalog --noout --del \
+ "${EROOT}"/usr/share/xml/scrollkeeper/dtds/${DTD_FILE} \
+ "${EROOT}"/etc/xml/catalog
+}