summaryrefslogtreecommitdiff
path: root/app-text/pspdftool
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pspdftool')
-rw-r--r--app-text/pspdftool/Manifest3
-rw-r--r--app-text/pspdftool/pspdftool-0.03.ebuild26
-rw-r--r--app-text/pspdftool/pspdftool-9999.ebuild37
3 files changed, 11 insertions, 55 deletions
diff --git a/app-text/pspdftool/Manifest b/app-text/pspdftool/Manifest
index adfb65daad54..674a2f209fcc 100644
--- a/app-text/pspdftool/Manifest
+++ b/app-text/pspdftool/Manifest
@@ -1,4 +1,3 @@
DIST pspdftool-0.03.tar.bz2 129936 BLAKE2B 100ae29a9d929475d90c0acd6c5e50b61c65d690489ef223238bd19f567757635e0b0e774ff4561aa8e41476dd9a270ef8abafb307ad354e4f919b5ce578cf9c SHA512 8e621719c59f79f7201e8221a851e85d11573fa1895a64ab5e77382fa1103004f70a38f98928a8ce4b5795ce89ac3e4a7a5eade772959e26e49d6db9cc7fe7ea
-EBUILD pspdftool-0.03.ebuild 882 BLAKE2B 0e0793ed9090b7a2218ef8bdd9d1fc50aec0a8b062eb608e2a2742c81f967129d060bbb1eb4972ef64f894c8525c1204480e03a6bd56c3626382ecaadc8a4e92 SHA512 2555568da3e8feb2a0bf29384b67f5204eeb61dcf176d976f2c5f66718a1ab9c0f377d3ad0a89169fe8fb7cfec13864a02fb48a275e9a50299932f87dc52e28c
-EBUILD pspdftool-9999.ebuild 806 BLAKE2B 83accfdbff4beacbbebbf52f22749868028d38b75641dc3171059b025c35ad0ce3bfb613cf90b4dacbe38a5464e1980acfe712cdbb7eb76d2333e27a3892f9b2 SHA512 a0a04775997d3cd9cd460ceb49f96d34cd225590a6d9f39ad65a80d0c04212e31641d621ffffad3742bba70bc1bddabe9e9adbdabaec2ac45ef90718481e227a
+EBUILD pspdftool-0.03.ebuild 615 BLAKE2B c58cc55562c843c6e5561f265db89495e9a39eed7fc346978c7839da98647538fe9e4377e3f2759965884035cf2ae4821f900851da0abc3fc2e5e405519fbb33 SHA512 689365db99cba7ed8771edf48c18cf44c0ed87afabaa0039ef94fe4920ed95bfc5828344f78d208c2e1b19ea73e982a63a6671a11b3131c945c94b1ac35f49da
MISC metadata.xml 498 BLAKE2B f7458570baa04efbeb3781aefd4187bc5f84b0d7279be2b903c2347cf3c32d7b6ec64c68222ddd665db4698be2b760eb5efeafdc188a49a80b03e0c4d1a95cb1 SHA512 55cb86516399e85deae15087e3625848416af0585a6805ed65245c644b85ed3e0509ed6b9cfd7013664eff00ba0c7c9d09951bac3fce306adb7b96829615452c
diff --git a/app-text/pspdftool/pspdftool-0.03.ebuild b/app-text/pspdftool/pspdftool-0.03.ebuild
index 5b6cbb7e2ecf..5dff5b9d0d33 100644
--- a/app-text/pspdftool/pspdftool-0.03.ebuild
+++ b/app-text/pspdftool/pspdftool-0.03.ebuild
@@ -1,31 +1,25 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-ESVN_REPO_URI="https://svn.code.sf.net/p/pspdftool/code/trunk"
-ESVN_PROJECT="pspdftool"
-
-[[ "${PV}" == "9999" ]] && EXTRA_ECLASS="subversion"
-inherit autotools ${EXTRA_ECLASS}
-unset EXTRA_ECLASS
+inherit autotools
DESCRIPTION="Tool for prepress preparation of PDF and PostScript documents"
HOMEPAGE="https://sourceforge.net/projects/pspdftool"
-[[ "${PV}" == "9999" ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
-[[ "${PV}" == "9999" ]] || \
-KEYWORDS="~amd64 ~x86"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE="zlib"
-DEPEND="zlib? ( sys-libs/zlib ) "
-RDEPEND="${DEPEND}"
+RDEPEND="zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}"
src_prepare() {
+ default
+ mv configure.{in,ac} || die
eautoreconf
}
@@ -35,5 +29,5 @@ src_configure() {
src_install() {
default
- rm -rf "${ED}"/usr/share/doc/${PN}*
+ rm -rf "${ED}"/usr/share/doc/${PN}* || die
}
diff --git a/app-text/pspdftool/pspdftool-9999.ebuild b/app-text/pspdftool/pspdftool-9999.ebuild
deleted file mode 100644
index 96932275aac6..000000000000
--- a/app-text/pspdftool/pspdftool-9999.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-ESVN_REPO_URI="https://svn.code.sf.net/p/pspdftool/code/trunk"
-ESVN_PROJECT="pspdftool"
-
-[[ "${PV}" == "9999" ]] && EXTRA_ECLASS="subversion"
-inherit autotools ${EXTRA_ECLASS}
-unset EXTRA_ECLASS
-
-DESCRIPTION="Tool for prepress preparation of PDF and PostScript documents"
-HOMEPAGE="https://sourceforge.net/projects/pspdftool"
-[[ "${PV}" == "9999" ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-[[ "${PV}" == "9999" ]] || \
-KEYWORDS="~amd64 ~x86"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="zlib"
-
-DEPEND="zlib? ( sys-libs/zlib ) "
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- eautoreconf
-}
-
-src_configure() {
- econf $(use_with zlib)
-}
-
-src_install() {
- default
- rm -rf "${ED}"/usr/share/doc/${PN}*
-}