summaryrefslogtreecommitdiff
path: root/app-text/pdfpc/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pdfpc/files')
-rw-r--r--app-text/pdfpc/files/pdfpc-4.6.0-no-movies.patch59
-rw-r--r--app-text/pdfpc/files/pdfpc-4.6.0-vala-0.56.7.patch31
-rw-r--r--app-text/pdfpc/files/pdfpc-4.6.0-webkit2gtk-4.1.patch22
3 files changed, 112 insertions, 0 deletions
diff --git a/app-text/pdfpc/files/pdfpc-4.6.0-no-movies.patch b/app-text/pdfpc/files/pdfpc-4.6.0-no-movies.patch
new file mode 100644
index 000000000000..9767dc2a8093
--- /dev/null
+++ b/app-text/pdfpc/files/pdfpc-4.6.0-no-movies.patch
@@ -0,0 +1,59 @@
+https://github.com/pdfpc/pdfpc/issues/672
+https://bugs.gentoo.org/904241
+
+commit a6501085b3e94eb4a01db18fe9dc15d51fcde3a3
+Author: Evgeny Stambulchik <fnevgeny@gmail.com>
+Date: Sat, 11 Feb 2023 23:04:19 +0200
+
+ Skip MOVIE actions when configured with -DMOVIES
+
+--- a/src/classes/action/link_action.vala
++++ b/src/classes/action/link_action.vala
+@@ -47,6 +47,7 @@
+ this.action = mapping.action.copy();
+ }
+
++#if MOVIES
+ /**
+ * Find movie on the current slide by its filename; there seems to be
+ * no better way with the current Glib Poppler bindings.
+@@ -71,6 +72,7 @@
+
+ return null;
+ }
++#endif
+
+ /**
+ * Create from the LinkMapping if the link is an internal link to a named
+@@ -91,6 +93,7 @@
+ return new_obj as ActionMapping;
+ }
+ break;
++#if MOVIES
+ case Poppler.ActionType.MOVIE:
+ unowned var movie_action = (Poppler.ActionMovie*) mapping.action;
+ var movie = movie_action.movie;
+@@ -100,6 +103,7 @@
+ return new_obj as ActionMapping;
+ }
+ break;
++#endif
+ default:
+ break;
+ }
+@@ -167,6 +171,7 @@
+ this.controller.switch_to_slide_number(slide_number);
+
+ break;
++#if MOVIES
+ case Poppler.ActionType.MOVIE:
+ unowned var action = (Poppler.ActionMovie*) this.action;
+ var movie = action.movie;
+@@ -192,6 +197,7 @@
+ }
+ }
+ break;
++#endif
+ default:
+ return false;
+ }
diff --git a/app-text/pdfpc/files/pdfpc-4.6.0-vala-0.56.7.patch b/app-text/pdfpc/files/pdfpc-4.6.0-vala-0.56.7.patch
new file mode 100644
index 000000000000..9aff761b471f
--- /dev/null
+++ b/app-text/pdfpc/files/pdfpc-4.6.0-vala-0.56.7.patch
@@ -0,0 +1,31 @@
+https://github.com/pdfpc/pdfpc/issues/686
+https://bugs.gentoo.org/904970
+
+commit 18beaecbbcc066e0d4c889b3aa3ecaa7351f7768
+Author: Evgeny Stambulchik <fnevgeny@gmail.com>
+Date: Tue, 25 Apr 2023 16:11:25 +0300
+
+ Create Lists of nullable types
+
+--- a/src/classes/drawings/drawing_commands.vala
++++ b/src/classes/drawings/drawing_commands.vala
+@@ -54,8 +54,8 @@
+ }
+
+ public void clear() {
+- this.drawing_commands = new List<DrawingCommand>();
+- this.redo_commands = new List<DrawingCommand>();
++ this.drawing_commands = new List<DrawingCommand?>();
++ this.redo_commands = new List<DrawingCommand?>();
+ }
+
+ public void add_line(bool is_eraser,
+@@ -70,7 +70,7 @@
+
+ // After adding a new line you can no longer redo the old
+ // path.
+- this.redo_commands = new List<DrawingCommand>(); // clear
++ this.redo_commands = new List<DrawingCommand?>(); // clear
+
+ bool new_path = true;
+ double epsilon = 1e-4; // Less than 0.1 pixel for a 1000x1000 img
diff --git a/app-text/pdfpc/files/pdfpc-4.6.0-webkit2gtk-4.1.patch b/app-text/pdfpc/files/pdfpc-4.6.0-webkit2gtk-4.1.patch
new file mode 100644
index 000000000000..2428314dd2fe
--- /dev/null
+++ b/app-text/pdfpc/files/pdfpc-4.6.0-webkit2gtk-4.1.patch
@@ -0,0 +1,22 @@
+--- pdfpc-4.6.0/src/CMakeLists.txt
++++ pdfpc-4.6.0/src/CMakeLists.txt
+@@ -30,8 +30,8 @@
+ endif ()
+
+ if (MDVIEW)
+- pkg_check_modules(WEBKIT REQUIRED webkit2gtk-4.0)
+- set(MDVIEW_PACKAGES webkit2gtk-4.0)
++ pkg_check_modules(WEBKIT REQUIRED webkit2gtk-4.1)
++ set(MDVIEW_PACKAGES webkit2gtk-4.1)
+ set(EXTRA_VALA_OPTIONS ${EXTRA_VALA_OPTIONS} -D MDVIEW)
+ endif ()
+
+@@ -136,7 +136,7 @@
+ vala_precompile(VALA_C
+ ${VALA_SRC}
+ PACKAGES
+- webkit2gtk-4.0
++ webkit2gtk-4.1
+ json-glib-1.0
+ gio-2.0
+ gee-0.8