summaryrefslogtreecommitdiff
path: root/app-text/pdfgrep/pdfgrep-2.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pdfgrep/pdfgrep-2.2.0.ebuild')
-rw-r--r--app-text/pdfgrep/pdfgrep-2.2.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/pdfgrep/pdfgrep-2.2.0.ebuild b/app-text/pdfgrep/pdfgrep-2.2.0.ebuild
new file mode 100644
index 000000000000..e0c242ff2d5a
--- /dev/null
+++ b/app-text/pdfgrep/pdfgrep-2.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A tool similar to grep which searches text in PDFs"
+HOMEPAGE="https://pdfgrep.org/"
+SRC_URI="https://www.pdfgrep.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="+pcre test unac"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-text/poppler:=[cxx]
+ dev-libs/libgcrypt:0=
+ pcre? ( dev-libs/libpcre2:= )
+ unac? ( app-text/unac )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig
+ test? (
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexrecommended
+ dev-util/dejagnu
+ )
+"
+
+DOCS="AUTHORS README.md NEWS.md"
+
+src_configure() {
+ econf \
+ $(use_with pcre libpcre) \
+ $(use_with unac)
+}