summaryrefslogtreecommitdiff
path: root/app-text/pdf2html
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pdf2html')
-rw-r--r--app-text/pdf2html/Manifest5
-rw-r--r--app-text/pdf2html/files/pdf2html-1.4-gentoo.patch54
-rw-r--r--app-text/pdf2html/files/pdf2html-1.4-libpng15.patch10
-rw-r--r--app-text/pdf2html/metadata.xml8
-rw-r--r--app-text/pdf2html/pdf2html-1.4.ebuild47
5 files changed, 124 insertions, 0 deletions
diff --git a/app-text/pdf2html/Manifest b/app-text/pdf2html/Manifest
new file mode 100644
index 000000000000..8d292e720d86
--- /dev/null
+++ b/app-text/pdf2html/Manifest
@@ -0,0 +1,5 @@
+AUX pdf2html-1.4-gentoo.patch 2277 BLAKE2B 4f1698da379021fc9e10cb8d04644cdc15ee45550cad0a2cc84a6f129d65d1887235206ffec4704c27a28b39f73eeae003a268a82a99dde9fc41eb40a5887224 SHA512 5639f201a04d14347e13e4ff13d3b88c534f614dfaa0dac6494420e71a0c29ccfef83984fbfe4b130d91fa21c97b32f615abb2c875a2b447e48f542ce976ced1
+AUX pdf2html-1.4-libpng15.patch 218 BLAKE2B b81712c66f6e2f90aa378861306e5184f791f6cc148b4ca7f574f48edee0b316e60a7b3b31da2ca5ac1bf5875965369e4892556f94a95f802f45174f7a215d47 SHA512 2a0a80a639432cfdb067872d12c9c6ab9e5239a2f945d0fe362d1abfa4e8d203b377981807c686fccc53ed1afaee0b651345c8cd959f8cf268b5728c4145cb56
+DIST pdf2html-1.4.tgz 22976 BLAKE2B d0177c34065dda391204813bc0c05b16ad8a711ca3d8f9ced060e2ee2c2f276fd7f0a713c5dfec934f7f95dd37641ef6aada9bab010ed9f457698c23554906a4 SHA512 00488c5e6303e1609294e7873c892866d19f3ee820f22f2d75436de22037bf3e4e1a565b7db29df5f6b20a76c5e2df4786e39e1d803cd7cca88274da65c7bbbb
+EBUILD pdf2html-1.4.ebuild 1083 BLAKE2B e8242e5b921e921a2ab8e737f2bc89d935c28f7d8d7d4823fa1353531cfd8e6fb7da3e354ec7af10e88e2811e363ae17ad693a7123356eac374354cb0d962b6a SHA512 0de389bd8d2c32a4daef3a433a9f336b3f22d0e6c1b1d8c485605b22a251dd99732db0b3994a75a32ac5272ed28b57db099e4b9a5879062b087069a4b907694d
+MISC metadata.xml 245 BLAKE2B ee3a163cfe0a4bc59c0dfb46f9ddb580e2d259b4d0e33cb4e684eb9e6d4b901bf97c6edd891f3b75a613a782f1b89318d0ee3ec9bee4e34c4441d9e8f4267678 SHA512 1653777623e2c15e1ce13229e396723b2cc9c214983e0f8592de98c01a31badc6c38c6735ed44f937d145883b43fb6f049af3eddb9ff96b18c96ccf8f67dd690
diff --git a/app-text/pdf2html/files/pdf2html-1.4-gentoo.patch b/app-text/pdf2html/files/pdf2html-1.4-gentoo.patch
new file mode 100644
index 000000000000..715b829b1c2a
--- /dev/null
+++ b/app-text/pdf2html/files/pdf2html-1.4-gentoo.patch
@@ -0,0 +1,54 @@
+--- pbm2png.c.orig 2003-09-16 20:12:55.000000000 +0900
++++ pbm2png.c 2004-02-21 22:09:57.415786664 +0900
+@@ -145,15 +145,13 @@
+ sprintf(string,"%s%d.html",basename,index);
+ f=fopen(string,"w");
+
+- fprintf(f,"<html><head><title>%s</title></head><body bgcolor=\"#000000\" text=\"#00ff00\" link=\"#ffff00\" vlink=\"#00ffff\"
+-alink=\"#ffff00\">\n",titlestring);
++ fprintf(f,"<html><head><title>%s</title></head><body bgcolor=\"#000000\" text=\"#00ff00\" link=\"#ffff00\" vlink=\"#00ffff\" alink=\"#ffff00\">\n",titlestring);
+ fprintf(f,"<h1>%s, Page %d</h1>\n",titlestring,index+pageoffset);
+ fprintf(f,"<p><table border=0 cellspacing=0 cellpadding=2><tr>");
+ fprintf(f,"<td valign=\"top\"><table border=0 cellpadding=0 cellspacing=0><tr><td>");
+ if (index)
+ {
+- fprintf(f,"<a href=\"%s%d.html\"><img src=\"left.png\" border=0
+-></a>\n",basename,index-1);
++ fprintf(f,"<a href=\"%s%d.html\"><img src=\"left.png\" border=0></a>\n",basename,index-1);
+ }
+ else
+ {
+@@ -162,18 +160,15 @@
+ fprintf(f,"</td><td>");
+ if (index<filenumber-1)
+ {
+- fprintf(f,"<a href=\"%s%d.html\">
+-<img src=\"right.png\" border=0></a>\n",basename,index+1);
++ fprintf(f,"<a href=\"%s%d.html\"> <img src=\"right.png\" border=0></a>\n",basename,index+1);
+ }
+ else
+ {
+ fprintf(f,"<img src=\"right.png\" border=0>\n");
+ }
+- fprintf(f,"</td></tr><tr><td colspan=2><a href=\"index.html\">
+-<img src=\"idx.png\" border=0 ></a></td>");
++ fprintf(f,"</td></tr><tr><td colspan=2><a href=\"index.html\"><img src=\"idx.png\" border=0 ></a></td>");
+ fprintf(f,"</tr></table>");
+- fprintf(f,"</td><td><img src=\"%s%d.png\" border=\"0\"
+-></td>\n</tr></table>",basename,index);
++ fprintf(f,"</td><td><img src=\"%s%d.png\" border=\"0\"></td>\n</tr></table>",basename,index);
+ fprintf(f,"</body></html>");
+ fclose(f);
+ }
+@@ -438,9 +433,8 @@
+ int a,z;
+
+ if (argc<7){
+- fprintf(stderr,"Usage: pbm2png <dpi> <basename> <titlestring>
+-<bottom_html_code> <pageoffset> <ifname> [starting_filenumber [invert]]\n");
+- return 0;
++ fprintf(stderr,"Usage: pbm2png <dpi> <basename> <titlestring> <bottom_html_code> <pageoffset> <ifname> [starting_filenumber [invert]]\n");
++ return 0;
+ }
+ dpi=atol(argv[1]);
+ ppm=dpi*1000/25.4;
diff --git a/app-text/pdf2html/files/pdf2html-1.4-libpng15.patch b/app-text/pdf2html/files/pdf2html-1.4-libpng15.patch
new file mode 100644
index 000000000000..72a0e1b65af9
--- /dev/null
+++ b/app-text/pdf2html/files/pdf2html-1.4-libpng15.patch
@@ -0,0 +1,10 @@
+--- pbm2png.c
++++ pbm2png.c
+@@ -23,6 +23,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <unistd.h>
++#include <zlib.h> /* Z_BEST_COMPRESSION */
+ #include <png.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
diff --git a/app-text/pdf2html/metadata.xml b/app-text/pdf2html/metadata.xml
new file mode 100644
index 000000000000..13170c3184d8
--- /dev/null
+++ b/app-text/pdf2html/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>tex@gentoo.org</email>
+ <name>Gentoo TeX Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-text/pdf2html/pdf2html-1.4.ebuild b/app-text/pdf2html/pdf2html-1.4.ebuild
new file mode 100644
index 000000000000..6447a075494d
--- /dev/null
+++ b/app-text/pdf2html/pdf2html-1.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Converts pdf files to html files"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~clock/twibright/pdf2html/"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/local/clock/pdf2html/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=">=media-libs/libpng-1.4
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ app-text/ghostscript-gpl
+ >=media-gfx/imagemagick-6"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-libpng15.patch
+}
+
+src_compile() {
+ tc-export CC
+ # Rewrite the Makefile as that's simpler
+ echo "LDLIBS=-lpng" > Makefile
+ echo "all: pbm2png" >> Makefile
+ emake
+ echo "pbm2eps9: pbm2eps9.o printer.o" > Makefile
+ emake pbm2eps9
+
+ echo "cp \"${EPREFIX}\"/usr/share/${P}/*.png ." >> pdf2html
+}
+
+src_install() {
+ dobin pbm2png pbm2eps9 pdf2html ps2eps9
+
+ insinto /usr/share/${P}
+ doins *.png *.html
+
+ dodoc CHANGELOG README VERSION
+}