summaryrefslogtreecommitdiff
path: root/app-text/openlp
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/openlp')
-rw-r--r--app-text/openlp/Manifest4
-rw-r--r--app-text/openlp/files/OpenLP-2.4.2-disable-tests.patch22
-rw-r--r--app-text/openlp/metadata.xml10
-rw-r--r--app-text/openlp/openlp-2.4.6.ebuild43
4 files changed, 79 insertions, 0 deletions
diff --git a/app-text/openlp/Manifest b/app-text/openlp/Manifest
new file mode 100644
index 000000000000..1c8a4f6bc5cd
--- /dev/null
+++ b/app-text/openlp/Manifest
@@ -0,0 +1,4 @@
+AUX OpenLP-2.4.2-disable-tests.patch 795 BLAKE2B 0741116f289c1ec368e401d66a798f87124971c069921813f71518155e78f04b6fa097686899c809f8cab84084ab1fde2141d30ba74e4f940c2bd2647069c939 SHA512 ac67c675a4793be0194ccdc522737de0fd2b7b008707c19cfb5dd4fd1c17e88a59c0d38cdfebb02272774da81dbf06ca8b897504abe3d37b5eeaf40b8d0c63f9
+DIST OpenLP-2.4.6.tar.gz 7303683 BLAKE2B 4e5b1a60c8eb8772cdecf453e8277a69cfb1cdd51ab6478425332b58c52319713dd411027a108113485ee7fdc4c770cb6f94a626b23c6cca82231311a62df08a SHA512 071ca83c6969c5281213dea5efe6dfc60a3d22b56534b93e2fd1f8e43760ba5cab851b6f4dca485a31254d2090e26ce640359cb9f9797d84b9509426061dfb7a
+EBUILD openlp-2.4.6.ebuild 1194 BLAKE2B 424025d14382ea8d10ef848ef18a50742a32e61c8d0c73a5535833693a984b7c7ef0318c59cf9c860c232e79e7ab4a23f12ae00ae9188a54945c479b43baac2e SHA512 e2ecde641044717dfa88c142385999cca20ab24faa888f8703fbd2583170f340545041bd359eb57aeca8f659e62986e486e74e9daada2547b3fc27144b47362b
+MISC metadata.xml 294 BLAKE2B f31b24e7a16fb99a7d3952c69a2d4f4a75afc12fb5e91954b20b07d9e1a43acf08bba842e5e08c73272be9db317bc2e52c5bc5c5e4e8e2d4c95acc787ef3387c SHA512 c8a3971d0143dec3196e52b3bf877b4b3e29041ec6c3c78cc20415cc9fb9640bd0762a651c3f7fd8c12b27b60d0fcf99eb8f0761c10337a9cbcf84e7e78c37e6
diff --git a/app-text/openlp/files/OpenLP-2.4.2-disable-tests.patch b/app-text/openlp/files/OpenLP-2.4.2-disable-tests.patch
new file mode 100644
index 000000000000..0b1de65e85af
--- /dev/null
+++ b/app-text/openlp/files/OpenLP-2.4.2-disable-tests.patch
@@ -0,0 +1,22 @@
+diff -urN a/setup.cfg b/setup.cfg
+--- a/setup.cfg 2016-06-25 13:20:56.000000000 -0500
++++ b/setup.cfg 2016-09-08 22:30:54.606413547 -0500
+@@ -2,3 +2,5 @@
+ exclude=resources.py,vlc.py
+ max-line-length = 120
+ ignore = E402
++[install]
++install_scripts=/usr/bin
+\ No newline at end of file
+diff -urN a/setup.py b/setup.py
+--- a/setup.py 2016-06-25 13:20:56.000000000 -0500
++++ b/setup.py 2016-09-08 22:30:50.523413394 -0500
+@@ -157,7 +157,7 @@
+ author_email='raoulsnyman@openlp.org',
+ url='http://openlp.org/',
+ license='GNU General Public License',
+- packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
++ packages=find_packages(exclude=['ez_setup', 'examples', 'tests', 'tests.*']),
+ scripts=['openlp.py'],
+ include_package_data=True,
+ zip_safe=False,
diff --git a/app-text/openlp/metadata.xml b/app-text/openlp/metadata.xml
new file mode 100644
index 000000000000..c14282681213
--- /dev/null
+++ b/app-text/openlp/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>anarchy@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">openlp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/openlp/openlp-2.4.6.ebuild b/app-text/openlp/openlp-2.4.6.ebuild
new file mode 100644
index 000000000000..2e89fb61736a
--- /dev/null
+++ b/app-text/openlp/openlp-2.4.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1
+
+DESCRIPTION="Free church presentation software"
+HOMEPAGE="https://openlp.org/"
+SRC_URI="https://get.openlp.org/"${PV}"/OpenLP-"${PV}".tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/alembic[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/pyenchant-1.3[${PYTHON_USEDEP}]
+ dev-python/pyodbc
+ dev-python/PyQt5[multimedia,gui,network,svg,webkit,${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/sip[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-0.5[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy-migrate[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/OpenLP-${PV}
+
+PATCHES=( "${FILESDIR}"/OpenLP-2.4.2-disable-tests.patch )
+
+python_install_all() {
+ distutils-r1_python_install_all
+ domenu resources/openlp.desktop
+ mv "${D}"/usr/bin/openlp.py "${D}"/usr/bin/openlp
+ doicon -s scalable resources/images/openlp.svg
+}