summaryrefslogtreecommitdiff
path: root/app-text/mupdf/files/mupdf-1.15-Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/mupdf/files/mupdf-1.15-Makefile.patch')
-rw-r--r--app-text/mupdf/files/mupdf-1.15-Makefile.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-text/mupdf/files/mupdf-1.15-Makefile.patch b/app-text/mupdf/files/mupdf-1.15-Makefile.patch
new file mode 100644
index 000000000000..cff348d95e42
--- /dev/null
+++ b/app-text/mupdf/files/mupdf-1.15-Makefile.patch
@@ -0,0 +1,42 @@
+diff --git a/Makefile b/Makefile
+index a9539342..e76b2c61 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,7 +3,7 @@
+ -include user.make
+
+ ifndef build
+- build := release
++ build := debug
+ endif
+
+ ifndef OUT
+@@ -187,13 +187,15 @@ generate: source/pdf/js/util.js.h
+
+ # --- Library ---
+
+-MUPDF_LIB = $(OUT)/libmupdf.a
+-THIRD_LIB = $(OUT)/libmupdf-third.a
++MUPDF_LIB = libmupdf.so.$(GENTOO_PV)
++MUPDF_STATIC = $(OUT)/libmupdf.a
++THIRD_LIB =
+ THREAD_LIB = $(OUT)/libmupdf-threads.a
+ PKCS7_LIB = $(OUT)/libmupdf-pkcs7.a
+
+-$(MUPDF_LIB) : $(MUPDF_OBJ)
+-$(THIRD_LIB) : $(THIRD_OBJ)
++$(MUPDF_LIB) : $(MUPDF_OBJ) $(THIRD_OBJ)
++ $(QUIET_LINK) $(CC) $(LDFLAGS) --shared -Wl,-soname -Wl,$(MUPDF_LIB) -o $@ $^ $(THIRD_LIBS) $(LIBS)
++$(MUPDF_STATIC): $(MUPDF_OBJ) $(THIRD_OBJ)
+ $(THREAD_LIB) : $(THREAD_OBJ)
+ $(PKCS7_LIB) : $(PKCS7_OBJ)
+
+@@ -322,7 +324,7 @@ install: libs apps
+
+ install -d $(DESTDIR)$(docdir)
+ install -d $(DESTDIR)$(docdir)/examples
+- install -m 644 README COPYING CHANGES $(DESTDIR)$(docdir)
++ install -m 644 README CHANGES $(DESTDIR)$(docdir)
+ install -m 644 docs/*.html docs/*.css docs/*.png $(DESTDIR)$(docdir)
+ install -m 644 docs/examples/* $(DESTDIR)$(docdir)/examples
+