summaryrefslogtreecommitdiff
path: root/app-text/libstaroffice
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libstaroffice')
-rw-r--r--app-text/libstaroffice/Manifest4
-rw-r--r--app-text/libstaroffice/libstaroffice-0.0.6.ebuild45
-rw-r--r--app-text/libstaroffice/libstaroffice-9999.ebuild2
3 files changed, 49 insertions, 2 deletions
diff --git a/app-text/libstaroffice/Manifest b/app-text/libstaroffice/Manifest
index 3fea585d34b1..934b46a0e3f3 100644
--- a/app-text/libstaroffice/Manifest
+++ b/app-text/libstaroffice/Manifest
@@ -1,4 +1,6 @@
DIST libstaroffice-0.0.5.tar.xz 682380 BLAKE2B 1f514873a7dcaf210fae77f32e88ce7e3e8652474f51616865cb95ff81e7ceb86d784aab0efc301b86b416264fd0eb59c9be717039fb6a4fb086c9d09ec124ae SHA512 937fc618bef79c9e25957f25f39bc829621b0a2da0213cbfb1b56c2b00d44f61bcd9db67d3e6329a4bd700a2c88fc743088381f58a96a87712b040c0ffc17fde
+DIST libstaroffice-0.0.6.tar.xz 706324 BLAKE2B 5ff692c85bb48a7cd4c1e05e0afcc3ab26d627254dcf0b4ba10314c6ec654d69e2910f031ec7b88c9d28c48fe6a7267cd2434d224dc980ad9e266273cbc65bfa SHA512 9b5313a069e29265875f2e744b6b39c261f578d72f67fdefe1454c092aaa28399e1b3dfcb3a2f881f9a60674e0115a29350fba3ee37fb442f0a837982077f324
EBUILD libstaroffice-0.0.5.ebuild 936 BLAKE2B 679e15b1ff60c00f82b0e2e847d3dae87877136aad694d07cdebc30b7cf2b7ea9f2b2011d019469b43bbe4c65f256225b1eb25e870d61adb9d7212e62fcb059a SHA512 fd6bdf21f011c4c47ef75a43e2e76305f2e57efcb67c713a23bb67b9422a4b1690b34048910c5e3b9576c03db934dc643312f19c9a638534979b12540538a087
-EBUILD libstaroffice-9999.ebuild 938 BLAKE2B fe93bb316bdd297ff1eb08b0301d0d8d923ccc72b6ec88e83939df5289a17315a10ded6dd0c09ec2e7126a8ac93648a30b0cc80d280fec64310254a617e4fdeb SHA512 fe4d35ba9f0d4e811532a5a70c56a2e3b0e576220000ee5d1bd9348f7bf36327c2fe8f14acaf9c5f2244480a5372a4b0406d31595a0376629cb4876d459c976a
+EBUILD libstaroffice-0.0.6.ebuild 938 BLAKE2B 11fc9d72cf695d1f5a5d113e1ffa1dbb93a9fe2e1d58ea560951566f80d604e3900d24c67c5ed02c54c5b6b8ecc1356b5fffeab9e5c3ba7408892146ca73e7ef SHA512 12a9e7e4a9555134c2a6950c80ee093f1fff810daaa3bff64880b04ece88d226e8e00eb55e2f76712bbc0a050b42ad03bf7a57ea60ed0e25345a37c85d968ac9
+EBUILD libstaroffice-9999.ebuild 938 BLAKE2B 11fc9d72cf695d1f5a5d113e1ffa1dbb93a9fe2e1d58ea560951566f80d604e3900d24c67c5ed02c54c5b6b8ecc1356b5fffeab9e5c3ba7408892146ca73e7ef SHA512 12a9e7e4a9555134c2a6950c80ee093f1fff810daaa3bff64880b04ece88d226e8e00eb55e2f76712bbc0a050b42ad03bf7a57ea60ed0e25345a37c85d968ac9
MISC metadata.xml 469 BLAKE2B a9dad122953621001465506893edb9b72c1b1e7a213f0cfbf155a985595d7d319041d95030ea80411a6c21c97aea0a2aa891538f26f31f46cfc4ac6ceb75d183 SHA512 2f352e3b818123c53c188dd2d31b7ea3acc1bdbe9dc127d44697512eeb2a7cf2e138b306c69c619cf7fb24d8424305ff4b3d5637fd945c2832a2dfb9ef7743c8
diff --git a/app-text/libstaroffice/libstaroffice-0.0.6.ebuild b/app-text/libstaroffice/libstaroffice-0.0.6.ebuild
new file mode 100644
index 000000000000..7578276aed40
--- /dev/null
+++ b/app-text/libstaroffice/libstaroffice-0.0.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/fosnola/libstaroffice.git"
+[[ ${PV} == 9999 ]] && inherit git-r3 autotools
+
+DESCRIPTION="Import filter for old StarOffice documents"
+HOMEPAGE="https://github.com/fosnola/libstaroffice"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1+ MPL-2.0 )"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+IUSE="debug doc tools +zlib"
+
+RDEPEND="
+ dev-libs/librevenge
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable debug) \
+ $(use_with doc docs) \
+ $(use_enable tools) \
+ $(use_enable zlib zip)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-text/libstaroffice/libstaroffice-9999.ebuild b/app-text/libstaroffice/libstaroffice-9999.ebuild
index 20a958e6735b..7578276aed40 100644
--- a/app-text/libstaroffice/libstaroffice-9999.ebuild
+++ b/app-text/libstaroffice/libstaroffice-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6